The show editor

The show editor

When you start FWsim, the show editor appears. In this window, you can plan shows and access the other program parts (e.g. the firework effect editor).

The 3D view shows the firing place, your firework, and the firing positions. In the timeline, you can change the ordering and timing of fireworks. From the toolbox, you can add new firing cues aswell as music and camera moves. The sidebar shows the settings for the currently selected cue. It also gives you access to the firing positions, camera settings, and functions for data export. Via the menu bar on top, many other features can be reached.

Adding cues and arranging them in time

  1. In the toolbox, click on “Single Shot”.
  2. A window appears, where you can select an effect.
  3. Click into the timeline. A new cue will be added.

In the timeline, time runs from left to right. The vertical tracks have no particular meaning: You can move your cues freely up and down these tracks, to organize your show better.

Adding more vertical tracks

If you need more vertical tracks, just click a cues with the left mouse button, hold it, and drag downwards. New tracks will appear.

Arranging effects in space

Select a single shot or stepper in the timeline. In the 3D view, a mortar appears, which shows you the location. In the case of a stepper, multiple mortars appear with arrows designating the start and end of the stepper.

To move a mortar or arrows, click them and leave the mouse button pressed. Then you can move them with your mouse. To rotate them left or right, hold the right mouse button and move your cursor sideways.

Cues in detail

Select a cue in the timeline. Then, you can edit its properties in the sidebar. More functions are available in the “Edit” menu on top, and via right-click on the cue.

Single Shots

To change the effect, click on the top left button or press F2. The box to its right allows selection of front or firing position (see Fronts). Under “Rotation”, you can change the mortar angle. Please note: in FWsim, you can rotate mortars left/right. In FWsim Pro, you can rotate along all axis (left/right, front/back, and rotating the shell inside the mortar).

Stepper

With a stepper, you have the same options as with single shots. Furthermore, you can adjust:

Music

To add music, click the “Music” button. You will then be asked for a filename. Select your file and click “OK”. Then, you can click into the timeline to add the music.

FWsim 3.0 supports all common audio formats: WAV, MP3, AAC, MP4, M4A, WEBM, FLAC, OGG, AIFF. You can also use ALAC files (Apple Lossless Audio Codec).

However, please note that you cannot use Music CDs with FWsim. This is because music CDs contain their data in a special file format. To convert CD music to audio files, you can use free software like Exact Audio Copy.

Note for users of FWsim Pro: When working with firing systems, please be aware that many firing systems require your music to start exactly at 0:00. To ensure that this is the case, grab the music cue with your mouse and move it towards the left as far as possible.

Camera Move

If you want the camera to move during the show, then add two “Camera Moves” via the toolbox. The first one defines the starting point (meaning, the camera will not move yet). The second “camera move” will trigger a movement to a new position, which you can define in the sidebar.

Details can be found under Cameras.

Insert another show (FWsim Pro only)

This feature allows you to add another show into your existing show. Please be aware: the show appears as a single cue, and it will not be possible to edit it.

Back to selection mode

When selecting Single Shot, Stepper or Camera Move, you can click into the timeline multiple times to add multiple instances of the selected cue. The cursor will become a cross:

When clicking “back to selection mode”, you will leave this insertion mode and get back the normal cursor.

Cameras

In FWsim, shows are displayed in a virtual 3D world. Since each show will have different arrangements and sizes, it can be important to adjust the camera.

In the sidebar, click the “Camera” tab:

At the top, you can change between static and moving camera.

Click static to define a camera position right in the sidebar. Click moving if you want to use a moving camera in your show. This option can only be selected after you have added “Camera Move” cues into the timeline. You can always switch between both options without losing your settings

Types of Camera

With the normal camera, you can adjust distance to the firing place and height.

The helicopter camera allows you a 360° flight around the firing place.

The Free Camera can be moved freely using mouse and keyboard. Please refer to the sidebar for instructions.

Setting up Camera Moves

If you want the camera to move during the show, add at least two “Camera Move” cues into your show. The first one will define the starting point (the camera will not move yet). Each subsequent “camera move” triggers movement towards a new position (which you can configure in the sidebar).

To adjust the length of the camera move, grab its right edge in the timeline and drag it. Since the first camera move in your show only defines the starting point, changing the length of that will not have any effect.

If your “camera move” cues have the same type (e.g. helicopter or free camera), a smooth motion will be created. If they have a different type, the viewpoint will be changed instantanously.

Edit multiple cues at once (only in FWsim Pro)

Hold SHIFT and then select multiple cues. You can now adjust all cues at once (e.g., change the effect, delete, copy, paste or move).

To select several cues, you can also drag a rectangle with the mouse in the timeline.

The “Edit” menu

This menu provides the following functions:

The “Show” menu

Working with two monitors (only in FWsim Pro)

In the “View” menu, you can change to two-monitor mode. On one monitor, you can place the timeline, and on the second one view the show.

Fronts

The term “fronts” refers to lines or points on which fireworks are placed.

In FWsim, effects can be placed on lines. In FWsim Pro, you can also place effects on points.

It is not necessary to use fronts at all - you can also place your mortars anywhere in space. However, in practice it will be very helpful to use the “Fronts” feature.

Creating fronts and aligning effects

In the sidebar, select “Fronts”. There, you can add, remove or modify fronts.

At the same time, your fronts (points or lines) will be shown in the 3D world:

You can now move these fronts in the 3D view, or enter the exact positions in the sidebar.

If you move effects in the 3D world, they will automatically snap onto fronts. If you do not want your effects to snap, hold the CTRL key while you move them.

Change Height (only FWsim Pro)

In FWsim Pro, it is possible to change the height of fronts. For that, activate the box “Set Height”, and adjust the height using the slider. When your front is a line, you can also setup a slope, so that start- and endpoint are on different heights.

Working with steppers and fronts

When you place steppers on fronts, please be aware:

If you span a stepper from one position to a different position, internally only the start- and endpoint will be on a position, the other shots will have no position assigned to them. Therefore, if you export a firing plan, no position information will show up for the shots in the middle. To circumvent this problem, we suggest to place steppers always on “Line” fronts. For future versions of FWsim Pro, we plan to make it possible to place steppers through multiple positions.

If you place steppers on “line” fronts, then FWsim remembers the position, the angle and the number of shots of the previously seleted stepper and uses it when placing the next stepper.

The position of a stepper is always stored relative to its front. For example, if you create a stepper that covers 50% of a line, and then put this stepper on a different line, then it will also cover 50% of the space there.

Flamejets and Lights (FWsim Pro)

FWsim Pro provides a very basic visualization for Flamejets and lights. The software also allows you to define DMX channels and values.

How to add DMX devices and cues to your show

In the toolbox on the right-hand side of the screen, click “DMX”. A list will popup, showing all the available devices. Click “Add” to add a new DMX device.

Each DMX device has the following attributes:

Each DMX cue has the following attributes:

Each cue corresponds to a DMX channel at a certain value. The channel will remain at this value as long as the cue persists, and the channel value will be set to 0 when the cue ends. You can change the length of the DMX cue by selecting the right edge with the mouse and dragging.

For lights, the DMX value determines the brightness. For flamejets, the DMX value does not affect the simulation in any way - simply set the channel to the value that your specific model of flamejet requires.

How to edit DMX cues

Right-click the cue in the timeline and select “Change DMX Device”. Here, you can select a different device for your cue or edit the attributes of the device. Please note that the device-specific attributes (type, DMX universe, DMX channel, light color) are stored per device, and several cues might refer to one device. This means, if you click “Change DMX Device” on one cue and change the light color, all other cues using the same light will also be affected.

How to export DMX data

Please note: DMX data can only be exported to the Piroshow, Pyromac and Firetek systems. At the moment, there is no way to export DMX data for other systems, or to CSV. Please contact us if you want to use DMX data with other systems.

Simply export data for your firing system, as you do normally. The DMX data will be included if your firing system is among the previously mentioned systems. For all other systems, your firework cues will be exported normally while the DMX data will be ignored.