The Firework Editor

The Firework Editor

Click Tools → Firework Editor to open the firework effects editor. A window will appear in which you can select different effect types. You can select one of the suggested effect types, but you can also select “New Empty Firework” to start from scratch.

The Firework Editor uses a component-based system, where you arrange different building blocks.

Overview

In the middle, you see your effect (click on the 3D view to play it). On the right, you find the building block structure of your effect. Below, you can adjust the properties of the currently selected building block.

The building block system

Similar to real firework effects, different components are connected to each other. For example, a peony shell consists of a lifting charge, a bursting charge, and stars. In the FWsim effect editor, this shell would look like this:

We have a tree structure of components which contain other components: The shell contains a bursting charge (“Explosion”), which releases stars

This system allows to create very complex effects. For example:

To build a multibreak shell, simply add several explosions with different times.

To build pistil effects, add two “Star” components to an Explosion. On one of the stars, set the “speed, relative to explosion” to 50%.

To create palms and similar effects, add tails to stars. If you want only tails, with invisible stars, then select the black color on the stars.

Effect Editor components in detail

Shell

A spherical shell with lifting charge. You can select pre-defined calibers, or define launch speed and diameter yourself. Based on the diameter, FWsim calculates an approximate weight of your effect. This weight is independent of how many components you add, and is only used internally to calculate the flight path.

Below, you see the maximum height your shell with reach. If your shell explodes before reaching this height, then the actual height may never reach this height.

Mine

A base component for mines, single shots, comets, and so on. You still have to add an “Explosion”.

Bursting Charge (“Explosion”)

Stars

Tails

To generate star tails, add a “Tail” component to stars. Each star will be trailed by a tail, which you can configure as follows:

Ascent Effect

Can be added to a shell. Creates a tail trailing the shell as it rises. The parameters are the same as for Tails.

Ascent Star

Adds a star which is attached to the shell and burns while the shell flies. The timing (when it starts to appear, when it reaches full brightness, when it goes out) can be precisely adjusted.

Eruption

With this component, you can create roman candles. “Eruption” emits stars, one after the other.

Rocket

Can be used like a shell, but is simulated as a rocket. Therefore, you get different sounds and a different flight path.

Catherine Wheel

A simple 2D simulation of a catherine wheel, emitting sparks as it turns.

Cake

Allows you to create your own cakes. These cakes can contain arbitrary effects.

Step 1: Setup an empty cake and select some effects

In the fireworks editor, click File → New → New Empty Effect. Then, click “Add Component” → Cake.

Then, select which effects you want this cake to contain. There are two possibilites for that: You can either add components in the effect tree, or you can click “Add existing effect” to add an effect from the library.

These effects will now be displayed in the effect tree, directly beneath the cake:

Step 2: change the ordering

After having added effects to our cake, we now go back to the “Cake” component itself, and change the ordering:

In this example, we have the following ordering:

The last row is empty and can be used to add more lines.

Using the slider below the list, you can change the interval for all rows.

Step 3: further settings

Under “Shape”, you can configure a fan-style cake.

Under “simulated inaccuracies”, you can configure the amount of the simulated inaccuracies. FWsim simulates differences in total length (“interval variance”) and in the timing of individual shots.

Shell of Shells

Using a “shell of shells” component, you can make a shell emit further shells after explosion.

For example:

In this example, the large shell flies 2.1 seconds, explodes, and emits 7 smaller shells, which spread out and explode themselves after 1.9 seconds. The parameters (number of shells, shape of distribution) can be changed.

Tourbillon, Whistle, Farfalle

These special effects can be added to an explosion, just like stars. Afterwards, number and shape can be changed.

Crackling (Popping Flowers) and Crossette

These components can be added to stars. As soon as a star goes out, crackling or crossette will appear.

Location of effect files on disk

Your effect files will be stored under “My Documents” → “FW-Sim”, stored in one folder per “author name” (you can select the author name when you save an effect).

Using Windows Explorer, you can organize these effects into folders, and FWsim will keep that folder structure. Please make sure that FWsim is closed while you do that.

Please note that the name of an effect is stored inside the file. Therefore, renaming an effects file has no consequence.

To rename effects, use File → Rename. Warning: FWsim uses the name to identify the effect. If you rename an effect that’s already used in shows, then these shows will no longer play correctly.

Export effects as video (FWsim Pro only)

To create videos showing individual effects, there are two possibilities:

  1. In the effect editor, click File → Export Video to export individual effects.
  2. In the main window, click Extras → Firework Database to export several effects into multiple video files.

Store custom effect data using the “Firework Database” (only in FWsim Pro)

Alongside your self-created effects, you can save arbitrary data (e.g. price, manufacturer).

Click Tools → Preferences, and select “FWsim Pro”. Under “Firework Database Columns”, you can setup the data fields to be used (one per line). When you change these data fields, all existing data in effects will be kept - you will never lose data you already entered.

For example:

Now, we can open the fireworks database in the “Tools” menu. Here, we see columns for price and manufacturer, and we can enter data into these columns.