Preferences (Tools → Preferences)

Preferences (Tools → Preferences)

General Preferences

###Graphics Quality The higher the quality, the less images per second FWsim will generate. On weak PCs, this can lead to juttery and non-fluid playback.

This option has no effect on the export of video: During export, FWsim always uses the highest quality.

###Show Designer

When stopping playback, stop all effects: When this option is activate dand you stop playback, then all effects will stop immediately.

Select from Effect Library with Single Click: Normally, in the effect selection window, you need to select the effect and then click “OK”. If this option is activated, then just clicking the effect is enough.

Mark ascent times on cues: Shows bars on cues in the timeline, which indicate the times at which an effect is opened in the sky.

###Video Export Size You can choose between 480p, 720p and 1080p. Higher values lead to higher image quality, but export will take a little longer.

###Video Export Quality

Smoke: Simulates smoke created by explosions. This slows down the video export a lot.

Shadows from Buildings: If you use 3D buildings, then this option lets them produce realistic shadows.

Please note that both options only apply to exported videos, and not during playback.

###Vertical zoom in show editor Reduce this value to see more tracks simultaneously.

###Weekly update check We recommend leaving this on, so you always have the latest version.

###Use VSync If VSync is activated, your computer waits until the current image is drawn, before sending another image to the monitor. Therefore, FWsim needs to wait before drawing each image, reducing performance.

De-activating VSync can make FWsim a little bit faster. Please note: in very rare cases, your computer may overheat when VSync is disabled. This can only happen when your computer is dusty or insufficiently cooled. And most modern computers will just switch off when overheating, with no permanent damage. Therefore, the risk to your computer is very low. Still, we want to inform you of this small risk.

Preferences for FWsim Pro

###Show Company Logo in Videos Using this option, you can insert your company logo in videos. Use PNG files with alpha transparency to achieve a correct outline for your logo.

###Show Text in Videos Enter an arbitrary text to be shown in the video. You can use both text and logo at the same time.

###Firework Database Columns See Firework Database.

Snap Cues to other Cues

This feature is useful when you want multiple cues to fire at the same time. If activated, then cues will snap onto other cues when moving them on the timeline. You can temporarily disable this snapping by holding the CTRL key while moving a cue.

Video Export: Create PNG images instead of AVI video

Normally, when exporting a video, FWsim creates an AVI video file.

Due to technical reasons, this AVI file does not have the best quality.

To achieve higher quality, some manual work is necessary. Activate this box. Then, when export a video, you are prompted to select a directory (instead of a filename). The individual frames of the video will be saved as a series of PNG files, and the audio will be stored as WAV. Afterwards, you can use free software to create a very high quality video file from these PNG files (for example, VirtualDub ). If you have questions about this procedure, we are happy to help.

CSV Separator

Defines the character used to separate columns for CSV data export.

Auto-assign channels before export

See the “Export” chapter.

Show distances in show editor

Shows a ruler in the show editor 3D view. Also shows the precise positions while moving cues.

Note: To see dimensions in the firework editor, click View → Show Dimensions while in the firework editor.