Der Show-Editor

Der Show-Editor

Wenn Sie FWsim starten, erscheint der Show-Editor. In diesem Fenster können Sie Shows planen und auf die anderen Teile der Software zugreifen (z. B. den Feuerwerkseffekt-Editor, Voreinstellungen, Einstellungen).

Die 3D-Ansicht zeigt den Abbrennplatz, Ihr Feuerwerk und die Positionen. In der Timeline können Sie die Reihenfolge und das Timing der Feuerwerke ändern. Aus der Werkzeugleiste können Sie neue Zünd-Cues sowie Musik und Kamera-Keyframes hinzufügen. Die Seitenleiste zeigt die Einstellungen für das aktuell ausgewählte Cue. Sie bietet Ihnen auch Zugriff auf die Positionen, Kameraeinstellungen und Funktionen für Module und Datenexport (in FWsim Pro). Über die Menüleiste oben können viele weitere Funktionen erreicht werden.

Vollbildmodus

FWsim Pro startet standardmäßig im Fenstermodus. FWsim Basic & Creative Edition starten im Vollbildmodus. Sie können über das Menü „Ansicht“ im Show-Editor zwischen Vollbild- und Fenstermodus wechseln. Wenn Sie sich im Vollbildmodus befinden und zu anderen Anwendungen wechseln möchten, verwenden Sie das Windows-Tastaturkürzel ALT+TAB.

Cues hinzufügen und zeitlich anordnen

  1. Klicken Sie in der Werkzeugleiste auf „Einzelschuss“.
  2. Es erscheint ein Fenster, in dem Sie einen Effekt auswählen können.
  3. Klicken Sie in die Timeline. Ein neues Cue wird zur Timeline hinzugefügt. Das Cue enthält den Namen des ausgewählten Effekts und dessen Kaliber.

In der Timeline läuft die Zeit von links nach rechts. Die horizontalen Spuren haben keine besondere Bedeutung: Sie können Ihre Cues frei nach oben und unten zwischen diesen Spuren verschieben, um Ihre Show besser zu organisieren.

Weitere vertikale Spuren hinzufügen

Wenn Sie mehr vertikale Spuren benötigen, klicken Sie einfach mit der linken Maustaste auf ein Cue, halten Sie sie gedrückt und ziehen Sie nach unten. Es erscheinen neue Spuren.

Effekte im Raum anordnen

Wählen Sie einen Einzelschuss oder Stepper in der Timeline aus. In der 3D-Ansicht erscheint ein Mörser, der Ihnen die Position anzeigt. Bei einem Stepper erscheinen mehrere Mörser mit Pfeilen, die den Anfang und das Ende des Steppers markieren.

Um einen Mörser oder Pfeile zu verschieben, klicken Sie darauf und halten Sie die Maustaste gedrückt. Dann können Sie sie mit der Maus bewegen. Um sie nach links oder rechts zu drehen, halten Sie die rechte Maustaste gedrückt und bewegen Sie den Mauszeiger seitlich. Um ein genaueres Ergebnis zu erzielen, können Sie auf das Cue klicken und die Drehung (und andere Eigenschaften) über die Einstellungen in der Seitenleiste festlegen, insbesondere wenn Sie einen exakten und spezifischen Wert verwenden möchten.

Drehung verstehen

FWsim bietet verschiedene Möglichkeiten, Ihre Cues zu drehen:

Drehung nach links / rechts. Wenn Sie ein Cue in der Timeline auswählen, können Sie es in der 3D-Ansicht nach links oder rechts drehen. Links und rechts beziehen sich immer auf die Welt — die Richtung bleibt unabhängig von der Kameraposition gleich.

Drehung nach vorne / hinten. Möglicherweise möchten Sie Schüsse zum Publikum hin oder von ihm weg neigen. Diese Option ist standardmäßig ausgeblendet. Um sie zu aktivieren, gehen Sie zu Extras → Einstellungen. Nach der Aktivierung erscheint in der Seitenleiste ein Schieberegler für die Vorwärts-/Rückwärtsdrehung, wenn ein Cue ausgewählt ist. Bitte beachten Sie, dass die Rack-Verwaltung in FWsim die Vorwärts- oder Rückwärtsdrehung derzeit nicht berücksichtigt.

Ausrichtung. Bei Effekten wie Cakes oder Lichterbildern ist die Ausrichtung des Effekts von Bedeutung. Verwenden Sie Bearbeiten → „Ausrichtung umkehren“ (oder das im Menü angezeigte Tastaturkürzel), um einen Effekt um 180° zu drehen. Für feinere Anpassungen aktivieren Sie den Schieberegler für die Ausrichtung in den Einstellungen — damit können Sie die Ausrichtung in kleineren Schritten drehen.

Wenn Sie einen realen 3D-Standort verwenden…

Ausrichtung für reale 3D-Standorte. Wenn Sie einen Google-Earth-Standort laden, müssen Sie die Ausrichtung so einstellen, dass links und rechts der vom Publikum erwarteten Richtung entsprechen. Wenn Sie sich im Fenster für reale Standorte befinden, verwenden Sie den Ausrichtungs-Schieberegler, bis die Ansicht korrekt aussieht, und bestätigen Sie dann.

Cues im Detail

Wählen Sie ein Cue in der Timeline aus. Anschließend können Sie dessen Eigenschaften in der Seitenleiste bearbeiten. Weitere Funktionen stehen auch im Menü „Bearbeiten“ oben und per Rechtsklick auf das Cue zur Verfügung.

Singleshots

Um den Effekt zu ändern, klicken Sie auf die Schaltfläche oben links oder drücken Sie einfach F2. Das Feld rechts daneben ermöglicht die Auswahl der Position (siehe Positionen). Unter „Drehung“ können Sie den Mörserwinkel ändern. Bitte beachten Sie: In FWsim können Sie Mörser nach links/rechts drehen. In FWsim Pro können Sie entlang aller Achsen drehen (links/rechts, vorne/hinten und auch das Drehen der Bombe innerhalb des Mörsers).

Stepper

Bei einem Stepper haben Sie die gleichen Optionen wie bei Singleshots. Darüber hinaus können Sie Folgendes einstellen:

Mehrfachauswahl-Rechteck

Es ist nun möglich, mehrere Cues auszuwählen. Ein weißes Rechteck erscheint. Damit können Sie die Dauer des gesamten ausgewählten Blocks ändern (sodass die Cues zeitlich näher zusammenrücken oder weiter auseinanderdriften). Diese Funktion ist nur in FWsim Pro verfügbar.

Smart Clone

Wählen Sie ein oder mehrere Einzelschüsse (aber keine Stepper) aus, klicken Sie mit der rechten Maustaste darauf in der Timeline und wählen Sie „Smart Clone“. Diese Funktion ist nur in FWsim Pro verfügbar.

Musik

Um Musik hinzuzufügen, klicken Sie auf die Schaltfläche „Musik“. Sie werden dann nach einem Dateinamen gefragt. Wählen Sie Ihre Datei aus und klicken Sie auf „OK“. Danach können Sie in die Timeline klicken, um die Musik hinzuzufügen.

FWsim 3.0 unterstützt die gängigsten Audioformate: WAV, MP3, FLAC, OGG, AIFF. Leider wird das AAC-Format (verwendet für Apple iTunes) nicht unterstützt. Wenn Sie AAC-Dateien verwenden müssen, nutzen Sie bitte diesen Konverter, um sie verlustfrei in das FLAC-Format zu konvertieren. Beachten Sie, dass der Musik-Player auf Ihrem Computer FLAC-Dateien möglicherweise nicht öffnen kann – FWsim jedoch schon.

Bitte beachten Sie jedoch, dass Sie mit FWsim keine Audio-CDs verwenden können. Der Grund dafür ist, dass Musik-CDs ihre Daten in einem speziellen Dateiformat speichern. Um CD-Musik in Audiodateien umzuwandeln, können Sie kostenlose Software wie Exact Audio Copy verwenden.

Hinweis für Benutzer von FWsim Pro: Wenn Sie mit Zündsystemen arbeiten, beachten Sie bitte, dass viele Zündsysteme voraussetzen, dass Ihre Musik exakt bei 0:00 beginnt. Um dies sicherzustellen, greifen Sie das Musik-Cue mit der Maus und verschieben Sie es so weit wie möglich nach links.

So verwenden Sie Musik von YouTube in FWsim

Um Musik von YouTube ohne Qualitätsverlust in FWsim zu übernehmen, nutzen Sie bitte diesen YouTube-zu-FLAC-Konverter. Beachten Sie, dass die Musikplayer-Software auf Ihrem Computer FLAC-Dateien möglicherweise nicht öffnen kann – FWsim jedoch schon.

Musik schneiden und kombinieren

Es ist möglich, mehrere Musikstücke in die Timeline einzufügen. Sie können die Musikdateien jedoch nicht innerhalb von FWsim bearbeiten.

Wenn Sie einen Song kürzen oder mehrere Musikstücke kombinieren möchten, empfehlen wir die kostenlose Software Audacity:

  1. Öffnen Sie Ihre Musikdatei in Audacity.
  2. Um einen Song zu kürzen, suchen Sie eine passende Pause und löschen Sie den nicht benötigten Teil. Verwenden Sie Effekte > „Ausblenden“ (Fade Out), um das Ende sanft klingen zu lassen.
  3. Um Songs zu kombinieren, öffnen Sie die zweite Datei, kopieren Sie die gewünschte Auswahl, wechseln Sie zurück zur ersten Datei und fügen Sie sie am Ende ein. Wählen Sie den Übergangsbereich aus und wenden Sie Effekte > „Crossfade Clips“ für einen nahtlosen Übergang an.
  4. Exportieren Sie als MP3 (320 kbit/s) oder WAV für optimale Qualität und Kompatibilität mit FWsim.

Beat-Synchronisation

FWsim kann Beats in Ihrer Musik automatisch erkennen, sodass Sie Ihre Feuerwerks-Cues mit dem Rhythmus synchronisieren können.

Klicken Sie mit der rechten Maustaste auf den Zeitachsenbereich über der Timeline und wählen Sie „Synchronisieren“. Klicken Sie auf die Schaltfläche Automatisch, um die Analyse zu starten – dieser Vorgang dauert einige Minuten.

Überprüfen Sie die Ergebnisse nach Abschluss der Analyse. Wenn Sie zufrieden sind, klicken Sie auf OK, um die erkannten Beats zu übernehmen. Wenn die Ergebnisse nicht zufriedenstellend sind, verwenden Sie die Schaltfläche „Automatische Beats entfernen“ und setzen Sie Ihre Beats stattdessen manuell.

Kameras

In FWsim werden Shows in einer virtuellen 3D-Welt dargestellt. Da jede Show unterschiedliche Anordnungen und Größen hat, ist es wichtig, die Kameraeinstellungen anzupassen.

Klicken Sie in der Seitenleiste auf den Reiter „Kamera“:

Klicken Sie auf statisch, um eine Kameraposition direkt in der Seitenleiste zu definieren.

Klicken Sie auf bewegt, wenn Sie eine bewegte Kamera in Ihrer Show verwenden möchten.

Sie müssen zuerst Bewegte Kamera bearbeiten auswählen und Keyframes hinzufügen (dazu unten mehr).

Sie können jederzeit zwischen beiden Optionen wechseln, ohne Ihre Einstellungen zu verlieren.

Kameratypen

Mit der normalen Kamera können Sie einfach den Abstand zum Abbrennplatz und die Höhe anpassen.

Die Helikopter-Kamera ermöglicht Ihnen einen 360°-Flug um den Abbrennplatz. Dies ist die beste Option, wenn Sie einen realistischen „Drohnen-Effekt“ in Ihrer Simulation suchen.

Die Freie Kamera kann mit Maus und Tastatur frei bewegt werden. Bitte beachten Sie die Anweisungen auf dem Bildschirm.

Die Ansicht von oben ist nützlich für die präzise Positionierung und um einen guten Eindruck vom Layout des Geländes zu bekommen.

Speichern und Laden statischer Kamerapositionen

Wenn Sie die statische Kamera verwenden, nutzen Sie das „Speichern“-Symbol in der Seitenleiste, um Ihre Kameraposition zu speichern. Die Position wird dann in der Show gespeichert und Sie können später jederzeit zu ihr zurückkehren.

Um schnell zwischen diesen gespeicherten Positionen zu wechseln, verwenden Sie die Tastenkombinationen STRG + 1, STRG + 2 usw.

Kamerabewegungen einrichten

Wenn sich die Kamera während der Show bewegen soll, wählen Sie in der Seitenleiste Bewegte Kamera bearbeiten. Dadurch öffnet sich über der Timeline ein neuer Bereich, in dem Sie Kamerabewegungen konfigurieren können.

Um eine neue animierte Kameraposition hinzuzufügen, bewegen Sie den Abspielcursor an die gewünschte Position und drücken Sie in der Werkzeugleiste auf „Kamera-Keyframe hinzufügen“. Damit sich die Kamera tatsächlich bewegt, benötigen Sie mindestens zwei verschiedene Positionen zu unterschiedlichen Zeiten.

Klicken Sie auf ein Kamera-Keyframe, um dessen Eigenschaften anzupassen. Sie können ENTF drücken, um ein Keyframe zu entfernen. Sie können mehrere Keyframes auswählen, indem Sie die UMSCHALTTASTE gedrückt halten, und Sie können Keyframes kopieren/einfügen.

Kamerabewegungsdaten aus anderen 3D-Anwendungen importieren (FWsim Pro)

Möglicherweise möchten Sie FWsim-Videos mit Animationen kombinieren, die in anderer 3D-Software erstellt wurden. Dazu müssen Sie die Kameras zwischen FWsim und anderen 3D-Anwendungen abgleichen.

FWsim ermöglicht es Ihnen, eine Kamerabewegung in anderen Anwendungen zu gestalten und diese Kameradaten anschließend zu importieren. Es ist auch möglich, eine statische Kamera zu importieren; sie muss nicht animiert sein.

Die folgenden Anweisungen sind für die Open-Source-3D-Animationssoftware Blender verfasst. Wenn Sie Hilfe beim Importieren von Kamerabewegungen aus anderer Software in FWsim benötigen, lassen Sie es uns bitte wissen.

  1. Stellen Sie vor dem Fortfahren sicher, dass Sie FWsim Pro v3.5.0.14 oder eine neuere Version verwenden.
  2. Überprüfen Sie in Blender bitte, ob die Kamerapositionen in die Kamera selbst gebacken sind. Die Kamera darf kein untergeordnetes Objekt eines anderen animierten Objekts sein. Klicken Sie dazu auf die Kamera und drücken Sie „N“. Bewegen Sie sich dann durch die Timeline. Sie sollten die korrekten Positions- und Rotationswerte der Kamera sehen, wie sie sich im Laufe der Zeit ändern.
  3. Wählen Sie nur die Kamera aus.
  4. Klicken Sie auf Datei → Exportieren → „Collada (.dae)“.
  5. Aktivieren Sie rechts „Selection Only“.
  6. Nun müssen wir das Koordinatensystem anpassen. Das FWsim-Koordinatensystem unterscheidet sich vom Blender-Koordinatensystem. Das FWsim-Koordinatensystem ist wie folgt aufgebaut: X nach rechts, Y nach oben, Z in den Bildschirm hinein. Wählen Sie unter „Global Orientation“ die Optionen „Forward Axis: -Z“ und „Up Axis: Y“. Lassen Sie das Kontrollkästchen „Apply“ deaktiviert.
  7. Aktivieren Sie rechts unter „Anim“ die Option „Include Animations“. Der „Key Type“ muss auf „Samples“ und die Sampling-Rate auf 1 gesetzt sein.
  8. Speichern Sie diese .dae-Datei.
  9. Öffnen Sie in FWsim Pro Ihre Show oder erstellen Sie eine neue.
  10. Stellen Sie den Kameratyp auf „Bewegte Kamera bearbeiten“.
  11. Wenn bereits eine bewegte Kamera konfiguriert ist, klicken Sie auf Show → „Alle Kamerabewegungen löschen“.
  12. Klicken Sie auf Show → „Kamerabewegung aus anderer 3D-Software importieren“ und wählen Sie Ihre .dae-Datei aus.
  13. Wenn alles geklappt hat, sehen Sie den oberen Teil der Timeline mit orangen Symbolen gefüllt. Es gibt für jeden Frame der importierten Kameraanimation ein Keyframe-Symbol.
  14. Stellen Sie den Kameratyp auf „Bewegt“, um Ihre Kamerabewegung zu sehen, oder auf „Statisch“, um Ihre Show aus anderen Positionen zu betrachten.

Mehrere Cues gleichzeitig bearbeiten

Halten Sie die UMSCHALTTASTE gedrückt und klicken Sie dann auf mehrere Cues. Sie können nun alle Cues gleichzeitig anpassen (z. B. den Effekt ändern, löschen, kopieren, einfügen oder verschieben).

Alternativ können Sie auch mit der Maus ein Rechteck in der Timeline aufziehen: Klicken Sie auf einen leeren Bereich in der Timeline, halten Sie die linke Maustaste gedrückt und bewegen Sie dann Ihre Maus im Timeline-Bereich.

Video-Export

Klicken Sie auf Datei → „Video exportieren“, um ein qualitativ hochwertiges Video Ihrer Show zu erstellen.

Dateiformat wählen (AVI oder MP4)

Sie haben die Möglichkeit, das Dateiformat AVI oder MP4 zu wählen. Wenn Sie FWsim-Dateien in anderer Software weiterverarbeiten möchten (beispielsweise in Ihrem Videoschnittprogramm), sollten Sie das Format MP4 wählen. Andernfalls spielt es keine Rolle.

Die beiden Dateiformate (AVI und MP4) enthalten exakt die gleichen Videodaten, es gibt also keinen Unterschied in der Videoqualität. Auch bei der Audioqualität gibt es praktisch keinen Unterschied: Die AVI-Datei enthält WAV-Audio, das zu 100 % verlustfrei ist. Die MP4-Datei enthält MP3-Audio mit einer Bitrate von 320 kbit/s, was für alle praktischen Zwecke die gleiche hohe Qualität bietet.

Das Menü „Bearbeiten“

Dieses Menü bietet folgende Funktionen:

Das Menü „Show“

Elemente aus anderen Shows wiederverwenden und zusammenführen

Sie können standardisierte Sequenzen erstellen — wie ein bestimmtes Stepper-Muster oder einen Kometenfächer — und diese über mehrere Shows hinweg wiederverwenden.

Kopieren und Einfügen zwischen Shows. Öffnen Sie die Show-Datei, die die Elemente enthält, die Sie wiederverwenden möchten. Ziehen Sie in der Timeline ein Auswahlrechteck um die gewünschten Cues und drücken Sie STRG+C. Wechseln Sie dann zurück zu Ihrer Haupt-Show, bewegen Sie den Abspielcursor an die gewünschte Einfügestelle und drücken Sie STRG+V.

Bitte beachten Sie: Sie müssen Datei –> Öffnen verwenden, um zwischen Shows zu wechseln. Das zweimalige Starten von FWsim und das anschließende Kopieren und Einfügen zwischen den beiden funktioniert nicht.

Die eingefügten Cues erscheinen an der Cursorposition. Wenn die Quelldatei Positionen verwendet hat, die in der Ziel-Show nicht existieren (z. B. „F1“ bis „F5“), erstellt FWsim diese automatisch. Positionen werden nach Namen zugeordnet; verwenden Sie daher eine einheitliche Benennungskonvention für Ihre Show-Dateien, um sicherzustellen, dass die Elemente jedes Mal auf den richtigen Positionen landen.

Eine gesamte Show-Datei einfügen. Wenn Sie eine komplette Show anstelle ausgewählter Cues zusammenführen möchten, müssen Sie diese nicht separat öffnen. Verwenden Sie Show → „Andere Show einfügen“, um den Inhalt einer anderen Show-Datei an der aktuellen Position des Abspielcursors einzufügen.

Arbeiten mit zwei Monitoren (nur in FWsim Pro)

Im Menü „Ansicht“ können Sie in den Zwei-Monitor-Modus wechseln. Auf einem Monitor können Sie die Timeline platzieren und auf dem zweiten die Show ansehen.

Positionen

Der Begriff „Positionen“ bezieht sich auf Linien oder Punkte, an denen Feuerwerkseffekte in der Simulation und in der Realität platziert werden.

Es ist keineswegs zwingend erforderlich, Positionen zu verwenden – Sie können Ihre Mörser auch an beliebiger Stelle im Raum platzieren. Wenn Sie dies tun, können Sie jedoch die Datenexport-Funktionen nicht nutzen.

Positionen erstellen und Effekte ausrichten

Wählen Sie in der Seitenleiste „Positionen“. Dort können Sie Positionen hinzufügen, entfernen oder bearbeiten.

Gleichzeitig werden Ihre Positionen (Punkte oder Linien) in der 3D-Welt angezeigt:

Sie können diese Positionen nun in der 3D-Ansicht verschieben oder die genauen Positionen in die Felder der Seitenleiste eingeben.

Wenn Sie Effekte in der 3D-Welt bewegen, rasten diese automatisch an Positionen ein. Wenn Sie nicht möchten, dass Ihre Effekte einrasten, halten Sie die STRG-Taste gedrückt, während Sie sie bewegen.

Mehrere Positionen mit „Mehrfach hinzufügen“ hinzufügen (FWsim Pro & Hobbyist)

Anstatt Positionen einzeln hinzuzufügen, können Sie die Funktion „Mehrfach hinzufügen“ verwenden, um viele Positionen auf einmal einzurichten.

  1. Öffnen Sie den Reiter „Positionen“ in der Seitenleiste.
  2. Klicken Sie auf „Mehrfach hinzufügen“. Geben Sie die Anzahl der Positionen und ein Benennungsmuster ein (z. B. „Singleshots 01“).
  3. Wählen Sie zwischen einem Linien- oder Kreis-Layout.
  4. Für eine Linie: Ziehen Sie die erste und letzte Position, um die Linie in der 3D-Ansicht zu definieren.
  5. Für einen Kreis: Verschieben Sie den Mittelpunkt und greifen Sie dann den äußeren Griff, um den Radius festzulegen — die restlichen Positionen ordnen sich automatisch im Kreis an.

Um eine Reihe bestehender Positionen umzubenennen, verwenden Sie die Schaltfläche „Alle umbenennen“. Sie können sie numerisch (1, 2, 3) oder alphabetisch (A, B, C) benennen.

Höhe ändern (nur FWsim Pro)

In FWsim Pro ist es möglich, die Höhe von Positionen zu ändern. Aktivieren Sie dazu das Kontrollkästchen „Höhe festlegen“ und passen Sie die Höhe mit dem Schieberegler an. Wenn Ihre Position eine Linie ist, können Sie auch eine Neigung einrichten, sodass Start- und Endpunkt auf unterschiedlichen Höhen liegen.

Mit Steppern und Positionen arbeiten

Wenn Sie Stepper auf Positionen platzieren, beachten Sie bitte:

Wenn Sie einen Stepper von einer Position zu einer anderen Position spannen, befinden sich intern nur Start- und Endpunkt auf einer Position; den anderen Schüssen ist keine Position zugewiesen. Wenn Sie einen Zündplan exportieren, werden daher für die Schüsse in der Mitte keine Positionsinformationen angezeigt. Um dieses Problem zu umgehen, empfehlen wir, Stepper immer auf „Linien“-Positionen zu platzieren. Für zukünftige Versionen von FWsim Pro planen wir, es zu ermöglichen, Stepper über mehrere Positionen hinweg zu platzieren.

Wenn Sie Stepper auf „Linien“-Positionen platzieren, merkt sich FWsim die Position, den Winkel und die Schussanzahl des zuvor ausgewählten Steppers und verwendet diese beim Platzieren des nächsten Steppers.

Die Position eines Steppers wird immer relativ zu seiner Position gespeichert. Wenn Sie beispielsweise einen Stepper erstellen, der 50 % einer Linie abdeckt, und diesen Stepper dann auf eine andere Linie setzen, deckt er auch dort 50 % des Platzes ab.