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1 Introduction

Chapter Description: Learn how to use FWsim (Introduction)

This handbook covers FWsim Basic, FWsim Creative Edition and FWsim Pro. The first chapter contains a
series of quick-start tutorial designed to teach the basics of FWsim as efficiently as possible.

If you find anything missing, please contact us.

You also can download this handbook as PDF to read it offline.

2 Show Editor Quick-Start Tutorials

Chapter Description: Learn how to use FWsim to script your fireworks displays in this tutorial series.

This chapter contains a series of quick-start tutorial designed to teach the basics of FWsim quickly. You can
read these tutorials here or watch them in this Youtube Playlist: FWsim Fireworks Simulator Tutorial Series

2.1 Part 1 - Show Editor Overview

In this tutorial series you’ll learn how to create your first show in FWsim - step by step.

2.1.1 Show Editor Overview

Let’s take a closer look on the interface of FWsim. In the middle of our screen we will see the simulation of
our fireworks show. Furthermore, we can adjust our firing positions. At the bottom of our screen we see the
timeline. Here, we organize our fireworks to shoot at the right time. At the right-hand site we can configure
our shots, create firing positions and more. Below that, we can select which elements to insert - for example,
one shot or several shots of a firework.
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2.1.2 How to insert music

Let’s start to design our first show. I want to have some music which underlines my show. So, I just pick
some music of my choice in Windows Explorer, hold my mouse button and drag it to the FWsim timeline.

2.1.3 How to insert fireworks

Now I’m ready to add some fireworks. Let’s insert some fireworks that explode in the sky – I’ll choose “Single
Shot” and select a fireworks effect from the library. To see the simulation on my screen, I have to insert them
into the timeline via left click. I can adjust the angle by holding the right mouse button and moving the
mouse to the left or right.
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To fill the space under my shells I want some Comets. Comets simply shoot from the ground up. We want
several shots in a row, so we click “Stepper”. I insert the stepper into the timeline by clicking. On the right,
we can adjust the number of shots. Again, we use the right mouse button to change the two angles.

2.1.4 How to copy fireworks

To quickly build a large show, you can copy and paste what you already have. Simply right-click on a shot in
the timeline and select “Copy”. Then you right click on empty space in the timeline and choose “Paste”. You
can also drag a rectangle to select multiple cues, then copy and paste them all together. You can use the
keyboard shortcuts CTRL+C (copy), CTRL+X (cut) and CTRL+V (paste) to work faster.
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2.1.5 How to play the show

After you’ve created your show, you can press space or the play button on the right to play.

2.2 Part 2 - Creating Steppers and Positions

In this tutorial you’ll learn how to set up firing positions. Furthermore, we talk about the different options
for steppers.

2.2.1 How to add and configure positions

In the last video you’ve learned how to create a small fireworks show with FWsim. When you create a new
show, you will see either a line or a single firing position - depending on which edition of FWsim you use. We
now want to add more positions. To do that, we go to positions and click on “Add”. To move this position we
have two options. The easiest way is to click the position in the 3D view, hold your mouse button and move
it around. The more accurate and professional way is to enter coordinates in the sidebar. I’ll add another
firing positions, place them with 100m distance between them and give them names. Good and clear names
are important if you work with a lot of positions.

2.2.2 How to add a single fireworks/ stepper

Let’s add some fireworks. We start with some steppers. So we choose our desired effect and activate the
option “Insert several like that” to be able to add multiple copies. Now the steppers are all placed on the
same position. To change that, we have two options: We can select a different position from the list on the
right. Alternatively, we can drag the two arrows around in the 3D view.
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2.2.3 Which options do you have for your cues

In the sidebar, we have a bunch of options for our steppers. First, you can change the number of shots. You
can change the angles by typing in numbers - or simply use the right mouse button in the 3D view. Next, we
want to change the stepper duration. There are two options to change this. The simple way is to hold your
left mouse button at the end of the desired stepper on the timeline and move your mouse. If you need an
exact duration, you can simply type that into the box. Finally, we can configure how the shots are arranged.
If you want your stepper to speed up or slow down, you can use the option timing. If you want your stepper
to shoot in a different way - for example starting from the middle - you can change that under “Type”. If you
want to reverse a stepper or flip its angle, you can use the options in the Edit menu.

You can repeat these steps to fill your show as desired.

2.3 Part 3 - Shortcuts and Advanced Features

We will go over some useful keyboard shortcuts, advanced show editor features and give you some tips how
to rapidly design big shows.

2.3.1 How to work with the Effect Library

You’ve already worked with the effect library before. Now I want to show you some cool features that you
may not have seen yet. First of all we click “single firework” to open the effect library window. On the right,
you can change the color or the size of your desired firework. This does not change the original effect file,
rather, it modifies the color on-the-fly. On the left you’ll find the filter options for the library. This is very
helpful if you want to search for a specific effect. You can filter by type of firework effect. In the box below,
you can choose to see only your own effects, FWsim standard effects, or downloaded effects created by other
users. Below that, you can filter by the author of the effect file. If you are a fireworks professional working
with FWsim Pro, then you will see several additional filters here - including color and caliber.
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If you know exactly which effect or color you need in your show, you can search by keyword using the search
function at the top. If you want to add several copies of the same effect into the timeline, make sure you
have the option “Insert several like this” activated at the bottom right.

2.3.2 Must-Know Keyboard Shortcuts

If you already have some firework effects in your show and everything is in the right place, you might want
to change some fireworks without changing the timing. To do that, simply right click your cue and choose
“Change Firework” or press F2 after selected you desired cue. The effect library window will open, and you
can choose a different effect which replaces the effect currently used in your show.
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You can also select several shots in the timeline and then change the effect for all of them. If you need to fire
an effect at a very precise time, you can right click and choose “Enter time”. If you have selected several
effects, then all of them will be moved to the same time.

To reverse a stepper, simply press CTRL+R. To mirror a stepper, press F3. To insert a single firework, press
F. To insert a stepper, press S. You don’t need to memorize these shortcuts: You can see them right next to
each menu item.
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2.3.3 Extra features for FWsim Pro

If you are using FWsim Pro, you have access to a range of extra useful features:

You can undo any change by pressing CTRL+Z. After an UNDO, to re-do the change, press CTRL+Y. You
can UNDO and REDO several changes in a row. This allows you to quickly try something new, and revert it
immediately if you don’t like it. You can edit your show in table format. This is also called “script view”.
You can find this in the “Tools” menu. FWsim Pro provides a wide range of other features. These include:
Automatic Adressing, Chains of Cues, Multi-monitor support, Export to your firing system, Label Printing,
Excel Export, Calculation of Price and Total Explosive Mass, Sharing Effects with Colleagues, and Inserting
Shows into other shows. These will be explained in a future video.
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We hope that these features and keyboard shortcuts will allow you to work more efficiently - and be more
creative! If you want to suggest us a new feature, feel free to contact us.

2.4 Part 4 - Navigating in the timeline

In the last part we have learned about some useful shortcuts in FWsim. Now we will take a closer look at the
timeline and show you some tricks how to work more efficiently.

2.4.1 How to navigate in the imeline

First, I’ll add some music and some fireworks. Now, I would like to show you how to navigate really quickly
in the timeline. On the right you can see a fader. We can use this to zoom in and out. Alternatively, we can
press the CTRL key and use the mouse wheel. To add some more lines, we can simply click on a cue, hold
the left mouse button and drag it down. New lines will be automatically added - as many as you need. To
navigate in the timeline, you can use the horizontal and vertical scroll bars. But there are other ways: You
can simply click and hold your mouse wheel inside the timeline area. You can also use the arrow keys on
your keyboard to scroll one second forwards or backwards. If you want to jump to the beginning or to the
end of your show directly, you can press the “Home” or “End” keys.

To add a music file, simply select the file in Windows Explorer and drop it onto the timeline. When you
add music, that music is usually displayed both inside the timeline and on top of it. If you want to move it
around, drag it in the timeline. When you have found the right position for your music, we suggest you hide
it from the timeline. That way, you get more space and you avoid accidentally moving it. You can do that by
right-clicking on any free space in the timeline and disabling “Show Music in Timeline”.

In order to position your fireworks more accurately, you might want to see the music waveform in more detail.
You can right-click on the top area of the timeline and select “200%” to make it larger.
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If you want to change how many lines you can see at once, simply go to “Tools” and click on “Preferences”.
Here you can adjust the size of your lines with the fader “Vertical Zoom in Show Editor”. You can also make
the entire timeline area bigger or smaller.

To select multiple cues, you have two options: You can drag a rectangle with your mouse or keep the SHIFT
key pressed. You can also keep the SHIFT key pressed and drag multiple rectangles. We hope you find these
tips and shortcuts useful. If you have any question, feel free to contact us.
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2.5 Part 5 - Including 3D Models in your Fireworks Show

This time, you’ll learn to manage the environment settings in FWsim, how to use background images and
how to work with 3D Models.

2.5.1 General Simulation Settings

First, we look at the general settings that affect how all shows are displayed. We klick on “Tools” and then on
“Preferences”. Here we can choose our graphics quality, if we want to have some natural background sounds,
for example like wind, and also if the simulation should be realistic or accurate. “Realistic Simulation” means
that there will be added random variations to timings and heights. This is more realistic. But it means that
your firework effects will not explode exactly when you want them to. “Accurate Simulation” disables these
variations, to make timings and heights perfect.

2.5.2 Show Environment Settings

Every show has its own environment settings, with background images and 3D models. You can change
them for each show individually. We click on “Show” and then select “Scenery”. Here, we can choose a 360°
background. FWsim comes with three backgrounds, which look like this: These backgrounds are 360°. When
we rotate the camera (by clicking and holding the mouse wheel), we can look into any direction. You can
also load your own 2D background image. However, this will not look correct when you move the camera. If
you use a 2D background image, you should decide on one camera position that looks correct. (By the way:
We will explain camera control in one of the next videos)

Furthermore, we can choose a 3D-World. You can select a 3D world included in FWsim or one you created
yourself. In the next section of this video, you will learn how to create your own 3D world. Use the
“background brightness” slider to make your background darker or lighter. Usually it’s good to make it
somewhat dark, to get a good and realistic contrast to the bright fireworks. Use the “3D World Brightness”
slider to adjust the brightness of the ground and the 3D environment. You can enable or disable the ground
by clicking “Show Ground”.

Since 2023, FWsim is able to load not only custom 3D worlds, but also any real location in 3D - with the
Google Earth integration.
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2.5.3 How to work with the 3D-World Editor

To create your new 3D-World, click “Tools” and “3D-World-Editor”. We start with an empty world.

To add 3D models, we click on “add”. In this window we can select one of the 3D models included with
FWsim, or import our own. FWsim supports a variety of 3D model formats, however it is important that
your 3D model is not too big. Click the [link] (https://www.fwsim.com/find_free_3d_models.html) to learn
more about which 3D models work and where to find good 3D models. If you find a 3D model on the internet
that does not work with FWsim, [please let us know] (https://www.fwsim.com/contact.html).
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Click on a model to add it to the show. Now you have plenty of options to create spectacular scenery. You
can change the position of the 3D-Model, rotate it or simply scale it. You can also add as many 3D-Models
as you want. Everything is in the right place and you’re ready to use your new scenery? Navigate to File and
click on “Save 3D World” or simply use Ctrl + S. After you’ve closed the 3D-World Editor, you can choose
your new Scenery under “Show”, “Scenery” and “3D World”.

2.5.4 Loading real locations in 3D from Google Earth

Since 2023, it is also possible to load any location on the Earth by using Google and geographical coordinates.

Here’s how to do it:

1. Find the geographical coordinates (latitude and longitude) in decimal degrees, for example 51,503° /
0.00° for a location in London. To get coordinates, simply open Google Maps and right-click on the
point you want.

2. Open an existing show in FWsim or create a new show.
3. Click Show → Scenery, and select the “Real Location” option.
4. Enter your coordinates and click “Load”. Please make sure to use the right decimal separators. For

example, if your Windows is set to German number format, you need to enter “51,50178” whereas on
an English computer you would type “51.50178”.

5. Depending on the location you load, your camera might be below the terrain. If you don’t see anything,
move your camera upwards.
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Now it’s your turn. Just be Creative and create spectacular 3D-Worlds which you use as scenery for your
fireworks!

2.6 Part 6 - Achieving Perfect Synchronization

In this tutorial you’ll learn how to synchronize your fireworks with music. This is also our first tutorial video
recorded with FWsim version 3.4 This update brings a new dark design, as you can see - but most of the
buttons are still in the same places.

2.6.1 How to work with music in FWsim

You can simply drag and drop your music from Windows Explorer into the timeline. The music will show up
in the timeline, but also on top of the timeline. Inside the timeline, you can move your music to make it start
earlier or later. On top of the timeline, the music is displayed but it cannot be moved. When you click the
music, you can change the volume on the right hand side. If the music is at the right place and you don’t
need to move it, we recommend you hide it from the timeline. To do that, right-click on an empty portion of
the timeline and disable “Show Music in Timeline”. You might want to make the top area of the timeline
bigger, so you can better see the waveform. Simply right-click the waveform and choose a different size.

2.6.2 Synchronzation - the quick and easy way.

The easiest way to synchronize your fireworks to music is to take a close look at the soundwave and search
for peaks. When I want to design a show quickly, I use this method. After placing the cues approximately, I
repeatedly listen to a certain part and adjust my fireworks until they match the music nearly perfectly. If
I have to design a show rapidly, I repeat listen to the part and adjusting my added fireworks to the point
they match nearly perfect to the music. Here is a trick to make it easier to repeatedly view the same section:
Click the Gear Wheel next to the Timeline, and disable Play/Pause Mode. Now the cursor will jump back to
its starting position when you stop playback.
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2.6.3 Synchronization - the precise way.

When you want your timings to be really perfect, you should use some of the advanced tools for synchronization.
Right-click your music in the timeline and select “Synchronize with music.” A bigger and more detailed
waveform will appear. Here, we can set up certain beats that will then be displayed in our timeline. To
scroll around, use the scrollbar at the bottom or press and hold the middle mouse button. If you want to
add individual beats, click “Mark Single” or press the S key. You can add beats while paused or even while
playing. To move beats around, use the left mouse button.
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If your music has a regular tempo, then you can quickly create beats throughout the song. First, you need to
listen to a segment and count how many beats there are. In most songs, a measure of music will have 4 beats.
Place the cursor at the beginning of the phrase and press “Phrase”. Next, place the cursor at the ending of
the phrase and press “Phrase End”. By default, 16 markers are inserted at equal intervals. To change this,
we hover over the beginning or end point of the phrase, right-click and select “edit”. Now you can insert our
count of YY beats.

You can right-click on a phrase or single marker to delete them. Repeat these steps to set markers at
significant points in the song. When you are happy with your result, click OK. The markers are now shown
on top of the timeline. If you move cues, they will automatically snap to these times. To disable snapping
temporarily, hold the SHIFT key.

FWsim Pro only: In FWsim Pro v3.4, there are several new tools that are useful for music synchronization.
You can activate them by clicking the Gear Icon. “Insert and snap at Burst Time” will use the burst time
of shells as the reference for snapping. “Vertical reference line while dragging a cue” makes it easier to get
precise timing.

That’s it! Now it’s your turn to create perfectly synchronized shows with FWsim.

3 The show editor

Chapter Description: Handbook for the FWsim Show Editor. Learn how to script your pyrotechnic shows
and visualize them in live 3D preview.

When you start FWsim, the show editor appears. In this window, you can plan shows and access the other
parts of the software (e.g. the firework effect editor, preferences, settings).
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The 3D view shows the firing place, your firework, and the firing positions. In the timeline, you can change
the ordering and timing of fireworks. From the toolbox, you can add new firing cues as well as music and
camera key frames. The sidebar shows the settings for the currently selected cue. It also gives you access to
the firing positions, camera settings, and functions for modules and data export (in FWsim Pro). Via the
menu bar on top, many other features can be reached.

3.1 Fullscreen Mode

FWsim Pro by default starts in windowed mode. FWsim Basic & Creative Edition start in Fullscreen mode.
You can switch between Fullscreen and windowed mode by using the “View” menu in the Show Editor. If
you’re in fullscreen mode and want to switch to other applications, use the ALT+TAB Windows shortcut.

3.2 Adding cues and arranging them in time

1. In the toolbox, click on “Single Shot”.
2. A window appears, where you can select an effect.
3. Click into the timeline. A new cue will be added to the timeline. The cue contains the name of the

selected effect and its calibre.

In the timeline, time runs from left to right. The horizontal tracks have no particular meaning: you can move
your cues freely up and down these tracks, to organize your show better.

3.2.1 Adding more vertical tracks

If you need more vertical tracks, just click a cues with the left mouse button, hold it, and drag downwards.
New tracks will appear.
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3.3 Arranging effects in space

Select a single shot or stepper in the timeline. In the 3D view, a mortar appears, which shows you the
location. In the case of a stepper, multiple mortars appear with arrows designating the start and end of the
stepper.
To move a mortar or arrows, click them and leave the mouse button pressed. Then you can move them with
your mouse. To rotate them left or right, hold the right mouse button and move your cursor sideways. To get
a better result, you can click on the cue and set the rotation (and other properties) via the sidebar settings,
especially if you wanna use an exact and specific value.

3.4 Cues in detail

Select a cue in the timeline. Then, you can edit its properties in the sidebar. More functions are also available
in the “Edit” menu on top, and via right-click on the cue.

3.4.1 Single Shots

To change the effect, click on the top left button or just press F2. The box to its right allows selection of
firing position (see Positions). Under “Rotation”, you can change the mortar angle. Please note: in FWsim,
you can rotate mortars left/right. In FWsim Pro, you can rotate along all axis (left/right, front/back, and
also rotating the shell inside the mortar).

3.4.2 Stepper

With a stepper, you have the same options as with single shots. Furthermore, you can adjust:

• Total number of shots.
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• Duration (measured from first until the last shot). You can also change the duration directly in the
timeline, by dragging the right edge of the cue.

• Timing of firings (speeding up, or slowing down, or even).
• Type (this allows to vary the arrangement in time and space, for example you can have a stepper

running from the outside to the middle or vice-versa).

3.4.3 Multi Selection Rectangle

It is now possible to select multiple cues. A white rectangle appears. It allows you to change the duration
of the entire selected block (so the cues will move closer together or further apart in time). This feature is
available in FWsim Pro only.

3.4.4 Smart Clone

Select one or multiple single fireworks (but not steppers), right-click on them in the timeline, and select
“smart clone”. This feature is available in FWsim Pro only.

3.4.5 Music

To add music, click the “Music” button. You will then be asked for a filename. Select your file and click
“OK”. Then, you can click into the timeline to add the music.

FWsim 3.0 supports most common audio formats: WAV, MP3, FLAC, OGG, AIFF. Unfortunately, the AAC
format (used for Apple iTunes) is not supported. If you need to use AAC files, please use this converter
to convert it to the FLAC format - without losing quality. Note that the music player software on your
computer might not be able to open FLAC files - but FWsim can.

However, please note that you cannot use Music CDs with FWsim. This is because music CDs contain their
data in a special file format. To convert CD music to audio files, you can use free software like Exact Audio
Copy.

Note for users of FWsim Pro: When working with firing systems, please be aware that many firing systems
require your music to start exactly at 0:00. To ensure that this is the case, grab the music cue with your
mouse and move it towards the left as far as possible.

3.4.5.1 How to use music from YouTube in FWsim

To get music from YouTube into FWsim, without losing quality, please use this YouTube to FLAC converter.
Note that the music player software on your computer might not be able to open FLAC files - but FWsim
can.

3.4.5.2 How to use multiple pieces of music

It is possible to add multiple pieces of music into the timeline. However, you cannot edit the music files
within FWsim.

If you want to add multiple pieces of music, and you have one continuous show that plays in one go, we
recommend you edit the music using the free Audacity software. When you are finished editing, export your
file as WAV for optimum quality.
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3.5 Cameras

In FWsim, shows are displayed in a virtual 3D world. Since each show will have different arrangements and
sizes, it is important to adjust the camera settings.

In the sidebar, click the “Camera” tab:
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Click static to define a camera position right in the sidebar.
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Click moving if you want to use a moving camera in your show.

You need to select Edit Moving Camera first and add keyframes (more on that below).

You can always switch between both options without losing your settings.

3.5.1 Types of Camera

With the normal camera, you can just adjust distance to the firing site and height.

The helicopter camera allows you 360° flight around the firing site. This is the best option if yo are looking
for a realistic “drone effect” in your simulation.

The Free Camera can be moved freely using mouse and keyboard. Please refer to the instructions on the
screen.

The View from Above is useful for precise positioning, and for getting a good impression of the site layout.

3.5.2 Saving and Loading Static Camera Positions

When using the Static Camera, use the “Save” icon in he sidebar to remember your camera position. The
position is the stored in the show, and you can always go back to it later.

To quickly switch between these stored positions, use the shortcuts CTRL + 1, CTRL + 2 etc.

3.5.3 Setting up Camera Moves

If you want the camera to move during the show, select Edit Moving Camera in the sidebar. This will open a
new area on top of the timeline, in which you can configure camera moves.

To add a new animated camera position, move the playback cursor to the desired position and press “Add
Camera Keyframe” in the toolbox. To make the camera actually move, you need at least two different
positions at different times.

Click a camera keyframe to adjust its properties. You can press DELETE to remove a keyframe. You can
select multiple keyframes by holding the SHIFT key, and you can copy / paste keyframes.

3.5.4 Importing Camera Move Data from other 3D applications (FWsim Pro)

You might want to composit FWsim videos together with animation designed in other 3D software. For that,
you need to match up the cameras between FWsim and other 3D applications.

FWsim allows you to design a camera move in other applications, then import that camera data. It is also
possible to import a static camera, it doesn’t need to be animated.

The instructions below are written for the open-source Blender 3D animation software. If you need help
getting camera moves from other software into FWsim, please let us know.

1. Before continuing, make sure you have FWsim Pro v3.5.0.14 or later version.
2. In Blender, please check that the camera positions are baked into the camera itself. The camera must

not be a child object of some other animated object. To do that, please click the camera and press
“N”. Then, move through the timeline. You should see the correct position and rotation values of the
camera as they change over time.

3. Select the camera only.
4. Click File → Export → “Collada (.dae)”
5. Activate “Selection Only” on the right
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6. Now we need to adjust the coordinate system. The FWsim coordinate system is different from the
Blender coordinate system. The FWsim coordinate system is laid out like this: X to the right, Y
upwards, Z into the screen. Under “Global Orientation”, select “Forward Axis: -Z” and “Up Axis: Y”.
Leave the “Apply” checkbox unchecked.

7. Unter “Anim” on the right, activate “Include Animations”. The “Key Type” must be set to “Samples”
and the sampling rate must be set to 1.

8. Save that .dae file
9. In FWsim Pro, open your show or create a new one

10. Set the camera type to “Edit Moving Camera”
11. If there is already a moving camera configured, click Show → “Delete All Camera Moves”.
12. Click Show → “Import Camera Move from other 3D Software” and select your .dae file
13. If everything goes well, you will see the upper part of the timeline filled with orange icons. There will

be one keyframe icon for each frame of imported camera animation.
14. Set the camera type to “Moving” in order to see your camera move, or set it to “Static” in order to

view your show from other positions.

3.6 Edit multiple cues at once

Hold SHIFT and then click several cues. You can now adjust all cues at once (e.g., change the effect, delete,
copy, paste or move).

Alternatively, you can also drag a rectangle with the mouse in the timeline: Click on an empty area in the
timeline, hold down the left mouse button, and then move your mouse in the timeline area.

3.7 Video Export

Click File → “Export Video” to produce a high-quality video of your show.

3.7.1 Choosing a file format (AVI or MP4)

You have the option to select the AVI or the MP4 file format. If you want to process FWsim files in other
software (for example, in your video editor), then you should select the MP4 file format. Otherwise, it doesn’t
matter.

The two file formats (AVI and MP4) will contain the exact same video data, so there is no difference in video
quality. And there is no practical difference in audio quality: The AVI file contains WAV audio, which is
100% lossless. The MP4 file contains MP3 audio with a bitrate of 320kbit, which offers the same high quality
for all practical purposes.
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3.8 The “Edit” menu

This menu provides the following functions: * Undo/Redo * Copy and Paste Cues. Please note: cues will
be inserted at the point at which your mouse cursor is in the timeline. Tip: you can also use CTRL+C
(copy), CTRL+X (cut) and CTRL+V (paste). * Reverse Stepper : Makes the stepper run in the opposite
direction. * Mirror Stepper : Mirrors the stepper in space. * Invert Stepper rotation: Changes right-angled
steppers to left-angled, and vice-versa. * Align Stepper with Music: Allows to synchronize steppers with beats
in music. Beats in music need to be created first, by right-clicking on Music in the timeline and selecting
“Synchronize With Music”. * Change Effect (you can also click the cue and press F2) * Change Cue Comment
(only FWsim Pro): With this feature, you can add arbitrary comments to cues. These comments can be
included in exported firing plans. (You can also use SHIFT + F2) * Overwrite effect data for this cue (only
FWsim Pro): In FWsim Pro, arbitrary data (for example, price or manufacturer) can be saved alongside
effects. This function is available via Extras –> Effects Database. This data can be included in the exported
firing plan. In some cases, you may want to use a particular effect, but have different data show up in the
exported firing plan. This feature allows to do that.
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3.9 The “Show” menu

• Play: Plays the show.
• Play Looped: plays the show until you stop.
• Back to Start
• Insert Time and Remove Time
• Add Track at Bottom
• Removed Unused Tracks at Bottom
• Insert Empty Cue at Current Position
• Insert Other Show at Current Position
• Scenery allows you to use your own background images and 3D worlds. To use your own 3D models in

FWsim, use the 3D World Editor, available under “Tools”. Using that editor, create a new 3D world
and add the model to it. Then you can open the “scenery” menu and select the previously created 3D
world from the list.

3.10 Working with two monitors (only in FWsim Pro)

In the “View” menu, you can change to two-monitor mode. On one monitor, you can place the timeline, and
on the second one view the show.
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3.11 Positions

The term “positions” refers to lines or points on which firework effects are placed in the simulation and in the
reality.

It is not necessary to use positions at all - you can also place your mortars anywhere in space. However, in
practice it will be very helpful to work with the “Positions” feature even if you are not a professional user:
you will be able to move fireworks around the scenery by just one click instead of dragging effects with the
mouse. Also, positions are essential if you are creating a show that involves 3D models.

3.11.1 Creating positions and aligning effects

In the sidebar, select “Positions”. There, you can add, remove or modify positions.
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At the same time, your positions (points or lines) will be shown in the 3D world:
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You can now move these positions in the 3D view, or enter the exact positions in the sidebar fields.
If you move effects in the 3D world, they will automatically snap onto positions. If you do not want your
effects to snap, hold the CTRL key while you move them.

3.11.2 Change Height (only FWsim Pro)

In FWsim Pro, it is possible to change the height of positions. For that, activate the box “Set Height”, and
adjust the height using the slider. When your position is a line, you can also setup a slope, so that start- and
endpoint are on different heights.

3.11.3 Working with steppers and positions

When you place steppers on positions, please be aware:
If you span a stepper from one position to a different position, internally only the start- and endpoint will be
on a position, the other shots will have no position assigned to them. Therefore, if you export a firing plan,
no position information will show up for the shots in the middle. To circumvent this problem, we suggest to
place steppers always on “Line” positions. For future versions of FWsim Pro, we plan to make it possible to
place steppers through multiple positions.
If you place steppers on “line” positions, then FWsim remembers the position, the angle and the number of
shots of the previously seleted stepper and uses it when placing the next stepper.
The position of a stepper is always stored relative to its position. For example, if you create a stepper that
covers 50% of a line, and then put this stepper on a different line, then it will also cover 50% of the space
there.

4 Working with Flamejets and other devices (FWsim Pro)

Chapter Description: In addition to pyrotechnics of all kinds, FWsim also supports flamejets and other
devices. These devices can be controlled via DMX or via channels on your firing system.
In addition to working with pyrotechnics, FWsim also supports flamejets, lights and other devices. We are
actively working on supporting more devices over time.
Most of these devices can be controlled through multiple means:

a) Devices can be controlled via DMX. You can then export the data to a DMX-capable pyrotechnical
firing system.

b) Some devices can be controlled via electrical impulses. For example, many flamejets are controlled in
that way. For this, you need a firing system that supports customizable opening time - so an electrical
impulse is sent and maintained for a specified amount of time.

c) Finally, flamejets made by Explo can be controlled directly through the Explo system.

Please check whether these scenarios (DMX data or channels on your firing system) are supported for your
firing system on our list of firing systems supported in FWsim Pro.
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4.1 How to add DMX devices and cues to your show

In the toolbox on the right-hand side of the screen, click “Device”. A list will popup, showing all the available
devices. Click “Add” to add a new device.

You can select the device type, and then the method of control (see above).

4.1.1 The “Flamejet” device type

Use this device type for any model of simple flamejet.

For each cue, you will be able to set the DMX value. This value does not affect the simulation in any way -
simply set the channel to the value that your specific model of flamejet requires.

You can configure your flamejet to occupy multiple DMX channels. If you do this, then every channel will
receive the same DMX value. This is useful for some models of flamejets that need two channels (safety and
trigger).

Each cue corresponds to a DMX channel at a certain value. The channel will remain at this value as long as
the cue persists, and the channel value will be set to 0 when the cue ends. You can change the length of the
DMX cue by selecting the right edge with the mouse and dragging.

4.1.2 The “Light” device type.

For lights, the DMX value determines the brightness. Lights are simulated as point lights, and only support
one channel. The color can be configured, but is only used for visualization.

This is quite limited and cannot be used for most real DMX lights. If you have a more complex scenario,
please get in touch - we might be able to support it in a future update.

4.1.3 Explo WaveFlamer

This video explains how to do Explo Waveflamer in FWsim:

vid: https://www.youtube.com/watch?v=8weMiNxK7_Y

For more information, please refer to our Explo Flamejet Scripting page.

4.1.4 Galaxis G-Flame

For more information, please refer to our Galaxis G-Flame Scripting page.

4.1.5 Deli FX DF17 (3 heads)

For this device, each cue represents one of the three heads. If you want all three heads to fire simultaneously,
create 3 simultaneous cues.

4.1.6 Stage Line Pro FP-2

This device uses two DMX channels. FWsim automatically creates the correct DMX data.
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4.2 How to export DMX data

Many pyrotechnic firing systems allow playback of DMX data. Please check our list of supported firing
systems to find out if your system is supported.
If DMX export to your system is supported, simply export data for your firing system, as you do normally.
If DMX export to your system is not supported, please contact us. We are interested to support more and
more systems over time.

5 The Firework Editor

Chapter Description: Handbook for the FWsim Effects Editor. Learn how to build your inventory of fireworks
effects in 3D.
Click Tools → Firework Editor to open the firework effects editor. A window will appear in which you can
select different effect types. You can select one of the suggested effect types, but you can also select “New
Empty Firework” to start from scratch.
The Firework Editor uses a component-based system, where you arrange different building blocks.

5.1 Overview

In the middle, you see your effect (click on the 3D view to play it). On the right, you find the building block
structure of your effect. Below, you can adjust the properties of the currently selected building block.

5.2 The building block system

Similar to real firework effects, different components are connected to each other. For example, a peony shell
consists of a lifting charge, a bursting charge, and stars. In the FWsim effect editor, this shell would look like
this:
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We have a tree structure of components which contain other components: The shell contains a bursting
charge (“Explosion”), which releases stars

This system allows to create very complex effects. For example:

To build a multibreak shell, simply add several explosions with different times. If you want to build an italian
“stutata”, set several explosions at the same time.

To build pistil effects, add two “Star” components to an Explosion. On one of the stars, set the “speed,
relative to explosion” to 50%.

To create palms and similar effects, add tails to stars. If you want only tails, with invisible stars, then select
the black color on the stars.

5.3 Effect Editor components in detail

5.3.1 Shell

A spherical shell with lifting charge. You can select pre-defined calibers, or define launch speed and diameter
yourself. Based on the diameter, FWsim calculates an approximate weight of your effect. This weight is
independent of how many components you add, and is only used internally to calculate the flight path.

Below, you see the maximum height your shell with reach. If your shell explodes before reaching this height,
then the actual height may never reach this height.

5.3.2 Mine

A base component for mines, single shots, comets, and so on. You still have to add an “Explosion”.

5.3.3 Bursting Charge (“Explosion”)

• “Auto” : Select this option to set delay and explosion strength to default values, depending on the
caliber.

• Delay in Seconds
• Explosion strength: Determines how fast stars are emitted and thereby, how far the effect spreads.

5.3.4 Stars

• Color: Select a predefined color, or create your own by clicking on “Custom Color”.
• Number of Stars.
• Type: Select between different types of stars that have different sizes and may fall quicker or slower.
• Distribution: Change the shape of stars in the air (e.g. spherical, ring, heart, customized).
• Speed, relative to the explosion.
• Speed Variance: With low values, the stars have very uniform speeds. The shape will appear very

precise in the air. With higher values, more inaccuracies are simulated, and the effect will deviate from
a perfect shape, just like real fireworks never have perfect shape.
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• Rotation: allows you to rotate the stars relative to the shell. Please note that the shell opens in a
random orientation in the sky. Therefore, this option only has an effect if you add multiple “Star”
components to an effect.

• Burn duration: define maximum and minimum burn duratoin for stars. Every individual star will get a
random burn duration inside that range.

• Strobe, and Strobe Frequency
• Color change: it is also possible to manage different color phases during the star burn duration. This

will allow you to create better ghost shells, for example, easily.
• Birthtime: Usually, stars appear right after the explosion. If you increase this value, the stars will be

invisible initially and start glowing after some time.
• Birthtime Variance: Defines how precisely the “birthtime” values will be simulated. With higher values,

more inaccuracies will be simulated.

5.3.5 Tails

To generate star tails, add a “Tail” component to stars. Each star will be trailed by a tail, which you can
configure as follows:

• “Start at” and “end at”: defines, for which part of the stars’ flight path the tail will be emitted.
• Density: number of sparks per second
• Width
• Color
• Burn duration: changes how long the tail lingers in the air.
• Variance of burn duration: The higher the value, the more random the burn duration of the sparks.
• Strobe, Strobe Frequency: see Stars
• Crackle
• Particle Size

5.3.6 Ascent Effect

Can be added to a shell. Creates a tail trailing the shell as it rises. The parameters are the same as for Tails.

5.3.7 Ascent Star

Adds a star which is attached to the shell and burns while the shell flies. The timing (when it starts to
appear, when it reaches full brightness, when it goes out) can be precisely adjusted.
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5.3.8 Eruption

With this component, you can create roman candles and fountains. “Eruption” emits stars, one after the
other.

5.3.9 Rocket

Can be used like a shell, but is simulated as a rocket. Therefore, you get different sounds and a different
flight path.

5.3.10 Catherine Wheel

A simple 2D simulation of a catherine wheel, emitting sparks as it turns.

5.3.11 Cake

Allows you to create your own cakes. These cakes can contain arbitrary effects.

5.3.11.1 Step 1: Setup an empty cake and select some effects

In the fireworks editor, click File → New → New Empty Effect. Then, click “Add Component” → Cake.

Then, select which effects you want this cake to contain. There are two possibilites for that: You can either
add components in the effect tree, or you can click “Add existing effect” to add an effect from the library.

These effects will now be displayed in the effect tree, directly beneath the cake:
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5.3.11.2 Step 2: change the ordering

After having added effects to our cake, we now go back to the “Cake” component itself, and change the
ordering:
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In this example, we have the following ordering: * 3x comet in silver, 400ms interval * 3x mine in yellow,
400ms interval * 3x comet in silver, twice as fast (200ms interval) * 3x mine in yellow, 200ms interval * silver
comet and yellow mine fired simultaneously (interval 0ms).

The last row is empty and can be used to add more lines.

Using the slider below the list, you can change the interval for all rows.

5.3.11.3 Step 3: further settings

Under “Shape”, you can configure a fan-style cake.

Under “simulated inaccuracies”, you can configure the amount of the simulated inaccuracies. FWsim simulates
differences in total length (“interval variance”) and in the timing of individual shots.

5.3.12 Shell of Shells

Using a “shell of shells” component, you can make a shell emit further shells after explosion.

For example:

In this example, the large shell flies 2.1 seconds, explodes, and emits 7 smaller shells, which spread out
and explode themselves after 1.9 seconds. The parameters (number of shells, shape of distribution) can be
changed.

5.3.13 Tourbillon, Whistle, Farfalle

These special effects can be added to an explosion, just like stars. Afterwards, number and shape can be
changed.

5.3.14 Crackling (Popping Flowers) and Crossette

These components can be added to stars. As soon as a star goes out, crackling or crossette will appear with
the related sound effect.

5.4 How to create many effects efficiently (FWsim Pro)

You might want to bring a large number of real-world effects into FWsim. FWsim Pro gives you two extra
tools to make this process easy and fast.
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5.4.1 Custom Components

In most effects, tails are the most complex element. To create really realistic tails, many people layer several
tails on top of each other. You might want to create one type of tails, and then re-use that for many different
effects.

FWsim Pro 3.3 introduces Custom Effect Components. You can create one or several tails, and then bundle
them together in one Custom Component. This component can be attached to other effects. It is not copied,
but it is linked. That means, when you change the component later, all effects that contain this component
will change as well.

To create a custom tail component, please follow these steps:

1. Open the Effect Editor
2. Create your effect
3. Attach stars and tails
4. Select one of your tails
5. Click “Advanced” → “Create Component: Custom Tails”
6. Enter a name for your component
7. This tail, and all other tails from the same star, will be bundled in a component that can be re-used.

To create a custom ascent effect component, please follow these steps:

1. Open the Effect Editor
2. Create your effect
3. Attach one or several “ascent effects” or “ascent stars” to your effect
4. Select one of them
5. Click “Advanced” → “Create Component: Custom Ascent Effect”
6. Enter a name for your component
7. All ascent effects and ascent stars attached to this shell will be bundled in a component that can be

re-used.

To use the same component for another effect, please follow these steps:

1. Open the Effect Editor
2. Create your effect
3. Select your stars in the effect tree on the right side of the screen
4. Click the “Add Component” dropdown. You will your component that you previously created, and also

a list of special tails already included with FWsim.

To edit a component you have already created, please follow these steps:

1. Open any effect that uses this component
2. Click the component in the effects tree
3. Click the “Edit” button
4. Make your modifications
5. Re-save the component under the same name by following the steps outlined above.

To delete a component you no longer need, please follow these steps:

1. Before you proceed, please make sure this component is no longer used by any effects.
2. Close FWsim
3. Open the folder “Documents” → “FW-Sim”
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4. Click “Effect Components”
5. Here, you will find your components sorted by author name. Locate the one you no longer need and

delete it - or move it to a different location on your computer.

Watch also this video guide if you are interested.

5.4.2 Creating Color Variations

Often, you will want to create the same effect in several colors. FWsim offers three ways of accomplishing
that:

1. Create only one effect in the effects editor and then change the color while you edit your show.
2. Creating copies of your effect by hand
3. Use the new Color Variation tool available in FWsim Pro 3.3.

5.4.2.1 Method 1: Using the “Colorize” feature in the show editor

In the show editor, whenever you select an effect, you have the option to change its color. This is very easy
to do, however it has two disadvantages:

Disadvantage 1: When you add price, manufacturer ID or other data to your effect, and then you colorize it
in the show editor, this extra data will not change. Suppose you have a red peony at a cost of $20. The
green peony costs $30. You only create the red peony in the effect editor, and whenever you need the green
peony, you simple use the “Colorize” option in the show editor. Then your calculated price will be wrong.
You can work around this by clicking “Change Effect Data for this Cue” in the Edit menu. But this is not
very efficient, as it needs to be done for each effect individually. In our example, you would need to select
every use of “green peony”, click “Change Effect Data for this Cue” and change the price to $30.

Disadvantage 2: In the example above, the name will be displayed as “Peony Red - modified green” in the
timeline. This is not very easy to read.

5.4.2.2 Method 2: Creating copies of your effect by hand

Before FWsim 3.3, the best method of handling color variations was to create separate copies of your effect.
This can be a little bit cumbersome. When you change something, you need to re-create all those copies by
hand.

5.4.2.3 Method 3: The new Color Variation Tool, available in FWsim Pro 3.3

This tool is integrated in the effects editor and helps you create color variations of your effects easily.

How to create one effect with many color variations:

1. Create your effect in any color you like
2. Put #color# in the name. For example, call it “Peony #color#”. If you have color-changing stars,

then you should also include #color2#. For example: “Peony #color# to #color2#”. These words
(#color# and #color2#) will be replaced by the actual color by the tool.

3. Save your effect
4. Click “Advanced” → “Color Variation Tool”
5. The tool will guide you through the process of creating copies. It will open up a list, where you can

insert the colors you want - one on each line. If you have color-changing stars, you can indicate these
color changes by writing e.g. “Red → Green”.
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5.5 Location of effect files on disk

Your effect files will be stored under “My Documents” → “FW-Sim”, stored in one folder per “author name”
(you can select the author name when you save an effect).

Using Windows Explorer, you can organize these effects into folders, and FWsim will keep that folder structure.
Please make sure that FWsim is closed while you do that.

Please note that the name of an effect is stored inside the file. Therefore, renaming an effects file has no
consequence.

To rename effects, use File → Rename. Warning: FWsim uses the name to identify the effect. If you rename
an effect that’s already used in shows, then these shows will no longer play correctly.

5.6 Export effects as video (FWsim Pro)

To create videos showing individual effects, there are two possibilities:

1. In the effect editor, click File → Export Video to export individual effects.
2. In the main window, click Extras → Firework Database to export several effects into multiple video

files.

5.7 Store custom effect data using the “Firework Database” (FWsim Pro)

Alongside your self-created effects, you can save arbitrary data (e.g. price, manufacturer). This data can be
changed in two ways:

1. In the the “Firework Database” window, which can be found in the Tools menu. (for several effects)
2. Directly in the Effect Editor

5.7.1 How to configure which data fields are available

Click Tools → Preferences, and select “FWsim Pro”. Under “Firework Database Columns”, you can setup
the data fields to be used (one per line). When you change these data fields, all existing data in effects will
be kept - you will never lose data you already entered.

For example:

v 44



Handbook for FWsim v3 5 The Firework Editor

5.7.2 Editing data via the “Fireworks Database” window

Now, we can open the fireworks database in the “Tools” menu. Here, we see columns for price and manufacturer,
and we can enter data into these columns.

You can also use CTRL+C and CTRL+V to copy and paste. Copy and paste is available for individual cells,
and also for multiple cells simultaneously (hold the SHIFT key to select a range of cells, and the CONTROL
key to select several distinct cells).

Should you wish to clear many data fields at once, you can select several cells and press the DELETE key.
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5.7.3 Excel Export and Import of your Effects Inventory

In the Fireworks Database window, you can export all effects to an Excel file. You can make changes to this
file and then re-import it again using the Import button.

5.7.4 Editing data within the Effects Editor

While editing an effect, you may want to change its custom data. To do that, click File → “Change Type,
Caliber or Custom Data”.

The window offers the following options:

• Type: By default, FWsim automatically categorizes effects based on the simulation. You can change
the type here.

• Caliber: By default, FWsim displays the caliber that is defined under “Shell” or “Mine” in the effect
editor. For Cakes, no caliber is shown. You can change that here.

• Custom Data: Allows editing of the same data fields as the “Fireworks Database” window.
• “Show this window when saving a new effect”: Enable this to see this window every time you save an

effect for the first time.

5.8 Display cost information while editing your show (FWsim Pro)

While designing your show, you might want to display the overall cost of the show on screen. To do that, you
need to insert pricing data into your effects. You can only add pricing data to effects that you created or
downloaded. No pricing data can be inserted for the effects that come pre-installed with FWsim.

To achieve that, please follow these steps:

1. Click Tools → Preferences and select the “FWsim Pro” tab.
2. Activate the checkbox “Display Cost on Screen”. By default, the price is retrieved from the column in

the fireworks database named “Price”. You can change that if you want.
3. Under “Firework Database Columns”, add the name of the fireworks column database that you wish to

use for price. Normally it is called “Price”.
4. Open the Firework Database and fill out the prices of the effects. Make sure you include the currency

symbol, for example “23.50$” or “23.50 €”.
5. When you create a show with these effects, the total price will be displayed in the corner of the 3D view.

This video illustrates the procedure.

Please note: In FWsim 3.5, it is no longer necessary to include the currency symbol. You can simply type a
number and it will display as the default currency of your computer. For example, if your computer is set to
German language, it will be “€”.

5.8.1 What to do if price information is not displayed correctly

1. Please make sure that every effect you use has price information in the fireworks database.

2. If you use an FWsim version earlier than 3.5, please make sure that this price information in the
database contains a currency symbol. For example, “$ 22.5” and “22.5 $” both work, but “22.5” does
not work. This is only required for FWsim versions before 3.5.

3. Please make sure that in the Preferences, you have entered the right name of the column in the fireworks
database to use. By default it is called “Price”.
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5.9 Display Net Explosive Content (NEM, NEC) while editing your show
(FWsim Pro)

While designing your show, you might want to display the overall net explosive content (NEC) of all the
effects in the show. NEC is also commonly referred to as:

• NEQ (Net Explosive Quantity)
• NEW (Net Explosive Weight)
• NEM (Net Explosive Mass) - this term is commonly used in German language

You first need to insert NEC data into your effects. You can only add NEC data to effects that you created
or downloaded. No NEM/NEC data can be added to the effects that come pre-installed with FWsim.

Here’s how to add NEC data to your effects:

1. When you create a new effect, by default FWsim will ask you for extra data to save alongside your
effects. This might include Net Explosive Content, Product ID or Price. You can also access this popup
from the File menu in the effects editor.

2. When filling out the data, keep in mind that NEC must always be in grams. Valid values are, for
example, the number “200” or “200g”.

3. If you want to update the data of multiple effects, use the “Firework Database” in the Tools menu.
4. In order to get live NEC display while editing your show, open the Preferences. Under “FWsim Pro”,

activate “Display NEC on Screen”.
5. You will now see NEC data in the 3D view while editing your show. If data is missing for some effects,

FWsim will let you know.

6 Export to Firing Systems (FWsim Pro)

Chapter Description: Learn how to export your scripted fireworks shows from FWsim Pro to your firing
system.

FWsim Pro can export your show data to a variety of firing systems (see list of supported systems).

6.1 Preparing a show for data export

When creating a new show, FWsim Pro asks you which firing system to use. You can change that later in the
sidebar.

With most firing systems, FWsim Pro can generate the channel assignment for you.

First, create enough modules in the tab “modules” in the sidebar. Here, you can add modules and distribute
them in 3D space. By default, cues will be connected to those modules that are closest. However, you can
change that and configure modules to be used for specific firing positions only:
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If you select that modules should only be used for specific firing positions, then they will be hidden from the
3D view. Instead, their number will be displayed next to the name of the firing position. For example:
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In the “export” sidebar, you can also define whether to export a stepper as one firing impulse (with the other
shots connected pyrotechnically), or if you want to export one firing impulse per shot:

This setting can also be changed for each stepper individually. In order to do that, click the stepper and go
back to the “Export” tab in the sidebar.

6.2 Automatic channel assignment

By default, FWsim creates new channel assignments whenever you export. This can be disabled in the
preferences.

Channel assignment can be customized through a variety of options:

1. By using Stepper cues, and the “One Channel” or “Multiple Channel” option (see below).
2. By chaining cues (see below).
3. You can also define some channels manually and “lock” them, so that they are not overwritten by

FWsim. This allows you to set some channels manually and have others be auto-generated.
4. In the sidebar under “Export”, FWsim can be configured to assign pins in a certain order. This is

useful for better cable management in the field. For example, you may want to have cues sorted by
time, by caliber, or alphabetically.
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5. FWsim can also combine cues into one channel if they are fired roughly at the same time. For some firing
systems, this is done automatically based on the limitations of the system. To change that behaviour,
open the Sidebar, find “Settings for this show”, scroll down, and click the button “Advanced Settings”.

6.3 Steppers and Channels

In the sidebar of the main window, under “Export”, you can define the default stepper export setting for this
show:

• One Channel - only the first channel of a stepper will receive an address
• Multiple Channels - every shot of the stepper will receive an address.

6.3.1 How to run a stepper through multiple positions

When creating a stepper, FWsim can automatically put the individual stepper shots on the correct positions.
This is important for automatic channel assignment and for exporting plans. In order to make that work,
you’ll need to follow a few guidelines:

1. Make sure that your positions are on one line, with equal distance between them.
2. In the sidebar (on the right side of the show editor), under “Export”, activate the option “Put Stepper

elements on nearby positions”
3. Your stepper count must match the number of positions. For example, if you have 9 positions next

to each other, then your stepper must have count 3, 5 or 9 (so that every element is exactly on one
position).

When you follow these guidelines, FWsim will recognize that each individual stepper shot belongs to a specific
position. If you have an unusual case in which these instructions do not work, please let us know.

6.4 Chains

You may want to connect some cues pyrotechnically - so that several cues receive only one channel on the
firing system.
To do that, you can chain several cues together. By chaining cues, only one firing impulse will be generated
in the exported data. The chains will be illustrated in the timeline with arrows.
You can chain cues together in several ways:

1. Right-click the first cue in the timeline, and select “Chain Cues”. Then click the cue you want to chain
it with. (The very first cue in the chain will receive a channel, the next cues will not)

2. Alternatively, select an entire group of cues in the timeline. Then right-click and click “Chain Cues”.
3. Instead of right-clicking, you can also use the keyboard shortcut: CTRL+D.

After creating the chain, select Export → “Auto-Assign Channels” and the channels will be updated.

6.5 Creating re-usable chains

In the section on chains, you learn how to create chains of cues - so that several cues only receive one channel.
You may want to create chains that are being re-used in several places. Our recommended way of doing that
is creating a cake in the effect editor. You can load up that cake with any number of effects you want.
The only problem with that approach is that the cake shows up as type “Cake” in the effect selection window.
There is a simple solution for that: Click File → “Change Type, Caliber or Custom Data” in the effect editor
menu. (video demonstration )
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6.6 Manual Channel Assignment

To assign channels manually, click a cue and select the “Export” tab in the sidebar.

For a stepper, this tab will look like this:
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For a single shot, you will get the following display:
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You can enter the address in several different formats. For example, to enter “Module 2, Pin 5”, you can
type “2/5” or “2.5”. As soon as you enter an address manually, a lock will apear. The lock means that this
address can no longer be changed by the automatic channel assignment. This is useful when you want to use
automatic channel assignment, but set some specific channels manually.

If you don’t want the lock, click it and the channel will be unlocked again. During the next automatic channel
assignment, ths channel assignment will be overwritten without confirmation.

6.7 Sequences (Semi-Automatic Firing)

Some firing systems support “sequences”: After each sequence is fired, the system pauses and waits for a
button press before continuing. This is also known as “Semiautomatic Firing”. FWsim can currently export
sequences to the following firing systems:
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Cobra, Firelinx, Firetek (old format), Firetek New Format (v4 or newer), Firetek USB Transfer (old modules
only), Pyromac, Pyroneo, RFRemotech

If your firing system is not listed and you want to export sequences, please contact us.

In order to create a sequence:

1. Position the playback cursor wherever you want your sequence to start
2. Click Export → Start New Sequence
3. Enter a name for the sequence or just press ENTER if you don’t need a name
4. The sequence start will show up as a text comment in the timeline, ending with “»”. For example, if

you entered the sequence name “Cake Sequence”, then there will be a text comment “Cake Sequence »”.
5. You can change the sequence name at any time simply by editing the text comment. Make sure the “»”

at the end of the comment remain in place.

6.8 Assigning a Channel to Music

Many firing systems offer a dedicated music player. Usually, this player is its own module and starts the
music when firing channel 1.

There are two ways of assigning a channel to music:

6.8.1 Automatic (always on module 50)

1. Create a module with one channel. The module must have module nr 50.
2. Click your Music in the timeline, and activate “Assign Channel”.
3. When you then auto-assign channels, the music will always be put on Module 50, Channel 1.

6.8.2 Manual

1. Create a module with one channel. It can have any module number.
2. Click your Music in the timeline, select the “Data Export” tab on the right and activate “Assign

Channel”.
3. In the box below, enter your module and channel number.

6.9 Firing system export

Click Export → “Export to Firing System” to export your show to the previously defined system. We have
more specific instructions available for some systems - please check our (list of supported systems).

6.10 My firing system is not supported by FWsim

If your system is not supported yet, there are two things you can do:

1. send us a message and let us know what system you would like to use. We are always interested in
supporting more systems.

2. You could use the CSV export, and try to make it work for your firing system. You could also export
via CSV and then shuffle the data around with Microsoft Excel or other software. If you need help,
please let us know.
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7 Importing existing shows (FWsim Pro)

Chapter Description: Visualize your existing pyro shows from the Cobra, Explo, Firetek or other formats in
3D.

You may have older shows that you would like to visualize in FWsim. This is currently possible with the
following data formats:

Cobra, Explo ShowCreator, Firetek, Mongoose .fyr

To import a show, please follow these steps:

1. Click File → Import and select your format. If your preferred import format is not in this list, please
let us know.

2. Select your file
3. In the next window, you can define the positions. In most firing system formats, there is no field for

the position. Therefore, FWsim needs to know which position belongs to which module. Fill out the
“Position” field for every line.

• You may have one module serving multiple positions. Unfortunately, this scenario is not supported.
Please insert one position name and later split it apart by hand.

• You may have “twin positions”, where one cue is fired simultaneously on several positions and uses
the same channel and module number. To import such data, please put the names of all involved
positions separated by a vertical bar character. For example: Suppose you are using two modules,
both have module number 3, and they will be put on the “Left” and “Right” position respectively.
Write Left|Right into the position field.

4. Next, FWsim asks you how to connect the effect names in your import data to FWsim effects. Click
into each line under “Effect (fWsim)” to select an effect. When selecting an effect, you can also change
the Caliber and color. Note that the Rising Time is only displayed for the Explo import format, which
includes rising time information. Most other firing system data formats do not include rising time
information.

5. When you are finished, click OK. Note that you do not need to assign all effects - you can always
change them later via the timeline.

6. After clicking OK, open the Positions tab in the sidebar and move your positions to the appropriate
locations.

7. Finally, if there are some unassigned effects left, you can change them by clicking the cue on the timeline
and pressing F2. If there are multiple cues with the same effect, FWsim will ask if you want to modify
all of them.

8 Creating Plans and Labels (FWsim Pro)

Chapter Description: With FWsim Pro, you can easily create a variety of plans and labels for your fireworks
show.

With FWsim Pro, you can easily create a variety of plans from your shows.

8.1 Sample files

• Firing Plan listing the cues and used effects

– PDF Sample, firing plan with one list for all cues
– PDF Sample, firing plan with several lists, one for each position

• CSV file that can be opened in Microsoft Excel, or processed with other software
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– CSV sample file

• Labels for each Module

– Sample file with setting “One label per module”

• Labels for each Igniter

– Sample file with setting “One label per igniter”

• Labels for each Cue

– Sample file with setting “One label per cue”

These plans can be printed, sent via e-mail or viewed on smartphones.

8.2 CSV export

The CSV format is useful for export to Microsoft Excel, and to other software.

You can define which data columns you want to have in your CSV file. To achieve that, click Tools →
Preferences → FWsim Pro. There, you can select the used columns and arrange them freely:
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8.3 Firing Plans as HTML or PDF

FWsim Pro Firing Plans contain a list of all cues and a list of the effects used in the show.
The plan can be exported in HTML or PDF format. Both formats can be opened on any computer for
printing. The PDF format has a fixed page size, which you need to configure during export. The HTML
format can be flexibly printed on paper of different sizes.

8.4 Labels as PDF

FWsim Pro provides three different label formats:
One label per module (sample file). Generates a (relatively big) label for each module listing all the cues
connected to this module.
One label per igniter (sample file). This is useful when using the chain feature.
One label per cue (sample file). This is useful when using the chain feature.

9 Working with Drone Shows (FWsim Pro)

Chapter Description: FWsim Pro helps you to visualize drone shows combined with fireworks, in a realistic
3D environment.
Starting with version 3.5, FWsim Pro is able to import drone shows using the VVIZ format. The workflow is
as follows:

1. Plan your show in external drone show planning software, and export to VVIZ.
2. Import the show into FWsim Pro
3. (Optional) Put fireworks onto drones

9.1 General Instructions

9.1.1 Step 1: Plan your show in external drone show planning software

First, you need to choreograph your drone show in your drone show simulation software. Which software
you use will depend on the manufacturer of your drones. We recommend the Drotek system - their software
supports VVIZ export and they are very responsive to technical support requests.
If your drone simulation software does not offer VVIZ export, let us know.

9.1.2 Step 2: Import the show into FWsim Pro

You will find the VVIZ import in the Show menu. Upon import, a firing position will be created for every
drone in the show.
You can click the show in the timeline and adjust the size of the light dots in the sidebar on the right.

9.1.3 Step 3 (Optional) Put fireworks onto drones

Upon import, a firing position is created for every drone. This allows you to put shots onto moving drones.
How you export the data for triggering shots on drones will depend on your drone system. Contact us with
your specific scenario and we’d be happy to help you.
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9.1.4 How to update the show after it has been imported

Simply delete the drone show from your timeline and import it again. The firing positions (one for each
drone) will remain.

9.1.5 How to export Pyros on Drones

When importing a VVIZ drone show into FWsim, FWsim automatically creates a moving firing position for
each drone. This allows you to place single shots onto your drones.

You then might want to export this data back to your drone system. Here’s how to do that:

• Place your shots on drones.
• You do not need to select a firing system. You also do not need to place any modules.
• Click Export → “Export VVIZ Pyros on Drones”.
• Select a new file name. Do not overwrite the original VVIZ that you used to import the data in the

first place.

FWsim will output the original VVIZ file that you used to import earlier, with the following modifications:

• The movement of drones will be deleted
• Any existing light or pyro data will be deleted
• The pyros for each drone will then be added into the file.

You can then import VVIZ into your Drone control software - for example, the Lightshow Creator by Drotek.

9.2 Step by Step: How to plan Drone Shows with Fireworks using FWsim and
Drotek

In this tutorial, we will go over all the steps needed to plan a drone show using Drotek and FWsim.

Drotek is a French manufacturer of Drone show hardware and software. One of the ways to create Drotek
shows is by using their Blender add-on. Blender is an open source 3D animation software.

9.2.1 Installing Blender with the Drotek Add-On, and creating your show

Please follow these steps to install. Under the same link, you will find instructions how to create a show, plan
takeoff & landing, choreograph formations and much more.

Please note: The Lightshow Creator is only available to fireworks and event professionals who are using the
Drotek system or are considering acquiring it. If you would like to request access, please get in touch with
Drotek.

9.2.2 Exporting your Show from Blender into FWsim

1. When you are happy with your design in Blender, click “Export VVIZ” in the Drotek Add-On to create
a VVIZ file.

2. Create a new file in FWsim
3. Click Show → “Import .vviz Drone Show” and select your file
4. You will notice that FWsim has created a firing position for every drone in the show.
5. You can now add single shots onto Drones. You can also place fireworks on the ground.
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6. The new “Smart Clone” feature might be useful if you want to place a lot of cues on many drones:
Create one shot on one drone. Then, right-click and select “Smart Clone”. Activate “Multiple Positions”
and “Filter by position name”. Then, enter “Drone”. That way, your shot will be duplicated onto all
other drones.

9.2.3 Exporting firing data to your firing system, and to Drotek

1. You can perform automatic channel assignment, and export a script, using your ground firing system.
This only affects your ground shots. Shots on drones will not receive channels through the firing system,
and they will not be exported into your firing system script.

2. We are now ready to export those drone shots to the Drotek system. To do that, click Export →
“Export VVIZ Pyros on Drones”. This VVIZ file will only contain the cues to be fired. It does not
contain drone movement.

3. Switch back to Blender. Click Lightshow → Fire → Import, select the newly created VVIZ file.
4. Your firing data is now included in the Blender file, and can be used to trigger cues on the Drotek

drones.

Please note:

If your drone show starts at a time later than 0:00 in the FWsim timeline, the times that are exported will
be relative to that. For example, if your drone show starts at 0:10 and you have a single shot at 0:30, then
the single shot will be exported as 0:20 in the VVIZ file.

10 Preferences (Tools → Preferences)

Chapter Description: FWsim Handbook - the Preferences window in depth.

10.1 General Preferences

10.1.1 Graphics Quality

If you experience performance problems, try selecting a lower quality. Otherwise, we recommend always
picking the highest quality setting for a better result.

This option has no effect on the export of video: During export, FWsim always uses the highest quality.

10.1.2 Show Designer

When stopping playback, stop all effects: When this option is activate dand you stop playback, then all effects
will stop immediately.

Select from Effect Library with Single Click: Normally, in the effect selection window, you need to select the
effect and then click “OK”. If this option is activated, then just clicking the effect is enough.

Mark ascent times on cues: Shows bars on cues in the timeline, which indicate the times at which an effect is
opened in the sky.

10.1.3 Vertical zoom in show editor

Reduce this value to see more tracks simultaneously.
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10.1.4 Weekly update check

We recommend leaving this on, so you always have the latest FWsim version.

10.1.5 Use VSync

If VSync is activated, your computer waits until the current image is drawn, before sending another image to
the monitor. Therefore, FWsim needs to wait before drawing each image, reducing performance.

De-activating VSync can make FWsim a little bit faster. Please note: in very rare cases, your computer may
overheat when VSync is disabled. This can only happen when your computer is dusty or insufficiently cooled.
And most modern computers will just switch off when overheating, with no permanent damage. Therefore,
the risk to your computer is very low. Still, we want to inform you of this small risk.

10.1.6 Dark design

You can enable or turn off the dark mode in the preferences section.

10.1.7 Sparks

Ascent Sparks and Explosion Sparks can be disabled for all the effects in the preferences section.

10.1.8 Rotation

Rotation back/front is hidden by default in the sidebar, but it can be enabled in the preferences section.

10.2 Preferences for FWsim Pro

10.2.1 Show Company Logo in Videos

Using this option, you can insert your company logo in videos. Use PNG files with alpha transparency to
achieve a correct outline for your logo.

10.2.2 Show Text in Videos

Enter an arbitrary text to be shown in the video. You can use both text and logo at the same time.

10.2.3 Firework Database Columns

See Firework Database.

10.2.4 Snap Cues to other Cues

This feature is useful when you want multiple cues to fire at the same time. If activated, then cues will snap
onto other cues when moving them on the timeline. You can temporarily disable this snapping by holding
the CTRL key while moving a cue.
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10.2.5 Video Export: Create PNG images instead of AVI video

Normally, when exporting a video, FWsim creates an AVI video file. This is a compressed video file. Video
compression reduces the quality slightly.

To achieve the very best possible quality, you can ask FWsim to generate a series of PNG images, which you
can then combine to a video manually. If you’d like to do that, please activate the “PNG images” checkbox
in the preferences. Then, when export a video, you are prompted to select a directory (instead of a filename).
The individual frames of the video will be saved as a series of PNG files, and the audio will be stored as
WAV. Afterwards, you can use free software to create a very high quality video file from these PNG files (for
example, VirtualDub ). Contact us if you have questions about this procedure, we are happy to help.

10.2.6 CSV Separator

Defines the character used to separate columns for CSV data export.

10.2.7 Auto-assign channels before export

See the “Export” chapter.

10.2.8 Show distances in show editor

Shows a ruler in the show editor 3D view. Also shows the precise positions while moving cues.

Note: To see dimensions in the firework editor, click View → Show Dimensions while in the firework editor.

11 The World Editor

Chapter Description: FWsim allows you to combine 3D fireworks visualizations with your own 3D models.

FWsim allows you to create your own 3D worlds, with 3D models that you find on the internet. You can
launch the world editor via the “Tools” menu in the FWsim main window.

11.1 The “Objects” Tab

Here, you can import and arrange all your 3D models.

To find new 3D models, please read “How to find free 3D Models for FWsim” on the FWsim website.

To import a 3D model, click “Add” and then “Import”. FWsim supports a wide variety of file formats. You
can either select a 3D model file directly, or a ZIP archive containing your model.

If your 3D model does not work with FWsim, please contact us and we will help you find a solution.

11.2 The “Settings” Tab

Here, you can change the settings for your show.
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11.2.1 Display of Lines

You can enable or disable the display of lines. Many 3D models on the internet contain both solid objects and
lines. Sometimes these lines are an important part of the model (for example, they might represent power
lines, ropes or cables). But often, these lines are a visual distraction and the object looks better without.
Starting in FWsim 3.1.1, the display of lines is disabled by default.

11.2.2 Changing Ground

You also have the option of changing the ground texture. If you want to add your own ground textures,
please open your FWsim installation directory (normally at c: → “Program Files (x86)” → “FWsim”). Look
for the folder “Resources” and then “ground_textures”. You can add your own ground textures here. Make
sure your texture is quadratic and no bigger than 4096x4096 pixels. You can use JPG, PNG or DDS files
- but the file ending must always be “.dds”. So, for example you might want to use your own file called
“my_ground_texture.jpg”. Simply rename it to “my_ground_texture.dds”, and put it into that folder. Then,
re-start FWsim, and you can now select your texture from the list.

11.2.3 Changing the Sky

The ground texture is stored per 3D world, however, the sky background is stored as part of the show file
and can be changed by clicking Show → Scenery in the main window.
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