Documentation for FWsim Pro

This page documents the extra features of FWsim Pro.
The manual for the standard FWsim features is available here.

Multi-Monitor support

In single monitor mode, firework effects are selected via a popup.
FWsim in single-monitor modeFWsim in single-monitor mode
FWsim Pro offers an additional two-monitor mode. The entire show designer uses one monitor, and the fireworks selection is embedded into the window. The simulation is displayed on the other screen.
FWsim in two-monitor modeFWsim in two-monitor mode

Firework Database

In FWsim Pro, you can store custom data with your effects, for example: Click Tools -> Firework Database Editor to view and modify this data. All fields support Unicode, which means that any characters in Chinese or Japanese will work.

To configure the Data Fields

What you store is completely up to you. You can configure the fields under Tools -> Preferences. This just defines the data fields that will be visible all the time. When you delete a field there, you will not lose the effect data you have already entered, and you will still see it in the Firework Database Editor.

Video export for individual effects

All editions of FWsim can export shows as videos. The pro edition can additionally export individual effects.
To render a single effect as a video: Open it in the fireworks editor and click File -> Export Video.
To render multiple effects: Click Tools -> Firework Database Editor. Tick the box on several effects and click the "Export Video" button to render them all. You can select a directory and all effect videos will be stored there.

Video Export with Company Logo

You can select a company logo or company name to be included in videos. Go to Tools -> Preferences and select the "Pro" tab. The logo can be alpha-transparent. It is recommended to use a PNG file if your logo has transparency.

Sub-Shows: Insert shows into other shows

As a professional pyrotechnician, you may need to create several shows in a short timeframe, and react to different client demands (budget, location, ...). FWsim Pro allows you to build a show consisting of several individual parts. For example, you could create several 1-minute-shows with music. Later, you could combine several of them to create a 3-minute show.
To combine several small parts into a big show:
  1. Create the small parts first. Save them as individual .fws files.
  2. Select File -> New to create a new empty show.
  3. Select "Insert Another Show" at the bottom left of the screen.
  4. Select the show file you created previously.
  5. Repeat 2-4 for all the individual parts.
Note that after you insert show A into show B, any changes you do in A will not show up in B. You can even delete or move the original show file A.
The camera moves defined inside the sub-show are ignored, as they might conflict with those you setup in the main show. The music in the sub-show is played normally.

Data Export

FWsim Pro can export data to CSV, HTML, and a range of firing system formats. For more information, please see Data Export in FWsim Pro.